64-bit Vista and Meter-cable drivers/software?

So - almost four months later, have you installed the third-party driver yet, and did it work? I’m running Vista64, just got an UltraSmart a couple weeks ago, and was wondering if you’d had any luck.

Yes – and it worked fine, straight-off. (I finally also got the 64-bit driver for my Freestyle meters up and running.)

Scott Berger is the man. Thank you, thank you for the solution. Worked great.

Good question.

I’m using WIndows 7, 64-bit, so I expect my situation is “the same” as yours. During the install for CoPilot I thought I saw something about how I’d need to “download more software”, but it didn’t say anything more about it and now I’m not even sure I saw that screen - it just flashed by.

I ran out of time trying to download data last time I tried, but am just getting back to this now and will report back here if I have any success or any further questions.

[5 minutes later I’ve realized that there were LOTs of replies to this posting. The way it was presented on the screen, I just didn’t notice that. So I’ll go back thru the details and see if I can make Scott Berger’s solution also work on Windows 7. THANKs !!! -Kevin

I got it working fine in Win7 x64. I downloaded the WHQL drivers from the OEM FTDI site and got the VCP drivers (they merged with the D2XX model, so they’re both the same) here.

I just added this line to all the sections in both .inf files that had similar lines and it worked fine.

I followed the steps for “Scott Berger’s solution” and it does indeed work - on Windows 7.

How interesting. I didn’t have to do what you said, but it’s good info to have in case I figure out that what I’ve done isn’t working as well as it seems. I followed the steps for “Scott Berger’s solution” and it does indeed work - on Windows 7. But I haven’t tried to include anything about TAGs, yet, and that was my original goal so I’ll get back to that. I do think that it’s going to work cause I can indeed see a few months worth of data just having followed “Scott Berger’s solution” steps.

Abbott just ticks me off since ALL they have to do is add that 1 line a couple of times to the inf files. Kinda like the notebook guys that tie the video drivers to their BIOS so you can’t use generic ones and then they never update the drivers so you have to do the same kinds of hacks. Grrrrr.

Anyway, I’m glad it’s all working for you. :slight_smile:

What can I say… you ROCK!! Was at the end of my tether trying to get this to work on Win 7.

All good now… thanks heaps.

Well, good. That’s excellent. And it was also very thoughtful of you to have taken the time to post this.

where was the driver located ?

i too am having same problem

Yup. Works fine for me on Windows 7 / 64-bit. Just follow the instructions.
Glad YOU got it working, too.


Technically they have to go through the FDA again to have their app re-approved… Though unofficially they could put the modified driver rolled into a driver update, or some such but they couldn’t 1. Tell you how to install it or 2. mention that it exists UNLESS you initiate it. All kidding aside CoPilot is in need of some serious software update… In general im not a fan of CoPilot, and abbotts technical support… None of their current meters support meal tagging and when I called… I got a (well you can always tag them in the software), when your on MDI or a pump, that becomes a pain in the backside remembering what your tags were AFTER you upload the meter… Really think they need a full featured meter, such as the Ultrasmart or Accu Check’s complete…or even just add the tagging and some more information (Standard Dev and averages, I kind of like the Wavesense Jazz for a smaller meter that has a lot of good features) Perhaps well see something of this if the Freestyle InsuLynx gets approved in the US (but im not betting on that either)…

Now why cant anyone seem to use a standard mini or micro USB and doing the checksumming in software is beyond me (Most meters actually checksum the readings before they send it to a PC, and the PC software confirms the checksum… Lifescans protocol is a very obvious example of this…

i have found the drivers for the program now vista wont let me open them to tweek them can somepne please assist

Go to the start of this sub-thread ( Reply by Scott Berger on August 24, 2009 at 7:43pm
); there’s a link to the file. It will need to be unpacked, then installed, then edited before it will work.