Dexcom and One Touch Meter: No "PC" when Connected

The last couple of days I have noticed that when I connect my meter to my Dexcom I do not get “PC” in the meter window. Needless to say, the receiver vibrates and tells me there is no connection. Has anyone had this problem? Dexcom is sending me a new connection cable, since I tried a new One Touch meter and that didn’t help. On a separate note, I have not calibrated in over 24 hours due to this problem, but I have been testing. My meter has only been 25 points off from receiver’s values.

Had the same problem until I relized that the glucometer connection plug was not pushed all the way in.

Yep, you and Dexcom (and Olaf!) are trying things in the right order:

#1, be sure that both ends are pushed in all the way;
#2, try a different One-Touch-Ultra, with a fresh battery;
#3, switch to an alternate cable; then
#4, get a new Receiver.

I’ve always thought that it’s a good idea to OWN two calibration cables and two chargers, in case one gets damaged or lost. Dexcom charges about $20 each to send “spares” for these things.

It was the cable. Once I got a new one, the problem was solved.