Ezmanager max won't find my pump?

Well, it DOES, sort of, I see the serial # show up, but then it’s telling me “no pump found matching the selected model”

But I do have the ping selected in the drop down… and obviously it sees it because the serial # shows up in the box after I hit start, it just doesn’t want to work!

Any ideas? I tried calling tech support but no one can help me until tomorrow… freaking wonderful that I have to wait a whole WEEK for the software to show up when I expected it to be IN THE BOX with my pump, and it wasn’t, it finally gets here (at 6pm, of course) but won’t work, and now there’s no one available to help me. AWESOME Animas. JUST FREAKING AWESOME.

We’ll just stack this on top of the rest of the trouble I’ve been having with my sites. I’m so ready to just send everything back at this point and stay with MDI :frowning:

The EZ Manager software can be a bit troublesome. After selecting the Ping, you need to go to the “communications port” part of the screen, and select the port that your pump is on (usually the “last” port…the one with the highest number). On my PC it is COM4.

After doing that, assuming you have the pump properly placed in front of the IR device, SUSPENDED, and with ta screen displayed (any screen will do)… Keep pressing a button on the pump (up or down arrow) to keep the screen displayed, till the download starts. Once it does, you’ll not need to worry about keeping the menu displayed.

I’m sad to hear that you’re having such a terrible time with “Customer Support”. They’ve been great every time I’ve had to deal with them (got my Ping at the end of March).


I know your frustrated but take a few minutes and think about this. You can now change out a needle once every 3 to 4 days instead of taking shots 3 to 4+ times per day. If your having trouble with your site get in touch with your salesperson or whoever trained you and tell them you are having trouble. They can help you or give you some samples of other canulas to try. As for tech support just hang on until tomorrow morning and I am sure there will be someone available to help you. I know it all wants to make you pull your hair out but it still has to beat taking multiple shots per day and all the other headaches that come along with that.

If you can just get over this hump I’m sure you will love it.

I can barely get 36 hours (if I am lucky) out of an infusion set before they fail (with insulin leaking out, not just poor absorption, or questioning if it’s bad because of high numbers). I am not on super crazy high amounts of insulin either… more than I think I should need (see below), but nothing insane, and I’ve needed WAY more insulin while pregnant (up to 140-150u a day - I remember having to change reservoirs daily with my paradigm) and that never caused a problem, so I am really at a loss for what is happening now. I realize the site failures have nothing to do with Animas, and it’s most likely the insulin itself, because I had similar issues with Humalog when I first started pumping, but I used Novolog without much trouble until recently.

Since going back on the pump though (I spent 3 years on MDI after my MM pump was out of warranty and not working), it’s like my body is just rejecting the Novolog… like I’ve become allergic to it or something. It may have been triggered by trying Levemir at the end of July, which did not work for me AT ALL, and it seems like things just went downhill from there… at least in terms of control. Things never quite seemed the same since I switched back to Lantus. In the past 12 days though, I’ve had to adjust my I:C ratio from from 1:10 to 1:6, and I’m taking almost twice as much basal as I was Lantus, and my ISF has been almost cut in half… something just doesn’t add up there :frowning:

I just today got some Apidra to try, to see if that helps. I already had a wicked bad low from it (just from a correction using the ISF I used with Novolog), so I’ve reset all my basals and I:C’s and my ISF to what they were 3 years ago, and I feel like I’m starting all over in terms of figuring out basal rates and everything else. I wanted pumping to make things easier… and this, well, it just isn’t so far.

Back to the point though, I just want to be able to download my pump data and look at it :frowning: I even tried installing everything in WIndows 7 (I ma a mac user) and it gave me the exact same error after reading the pump serial #. I will be on the phone with Animas tomorrow… but I doubt the problem is me, or my computers.

II’ve been on Apidra for a couple of years. It hits your system a lot faster (usually starts working 15 minutes after delivery). I’ve also read that it “peaks” about 2 hours after you bolus. This has been true in my case.

FYI… you’ll be fiddling with your I:C ratios, basal rates, etc. for quite a while…till you find out exactly what is right for YOU. I went on the Ping (was on a Cozmo) last April, and had to modify all my Cozmo settings to find what “fit” the Ping (and me) the best. I’m still tweaking. I’ve got problems with very high BG’s after breakfast (1 serving of Special K Protein Plus sends my BG’s into the 260-280 range 2 hours after a meal). NONE of the other meals during the day do that. ALL cerials send me into the ozone in the morning.

Just changed my AM I:C ratioo from 1:7 to 1:5 to see if that helps.

Stick with it… YOU will win…


Well, an update, I called Animas yesterday morning and they immediately said they would send out another disk… no troubleshooting, nothing, just “we have to replace it”. Huh? I definitely didn’t make a mistake in ordering this… I had ONE option when I logged in and clicked on “get my free copy of ezmanager max” so it’s not like I messed up somehow. I am 99% sure that they sent me the NON-US version of the software (even though my box says US, the disk doesn’t say anything). I get a call this morning @ 8am saying that the software is BACKORDERED, and it won’t be shipping for “at least 7-10 days”.

I don’t understand that, honestly… the software is just burned on a printable CD-R!!! It’s not like it’s on a pressed disk that has to go to production. I use/print these sorts of disks all the time and it takes 10 minutes, max, including printing the disk.

Ugh, so now I get to wait EVEN LONGER >:( I will be livid if they send me the wrong thing again.

Since I use a Mac Pro Server with my software I will try to help you. There was a problem with the early software release, and this was updated in August 09. Some people received the old cd with their ping during this time. Also there was some problems with the USB cable. I received a new CD and USB cable and I have it currently working with a Mac Pro Server. Also I strongly suggest that you do a fresh reinstall installation of your operating system. Sometimes when you install software like the EZ-Max the install will not take. This should sort out your problem with the software.

It was a fresh OS X install… I got my iMac back from apple last week after a hard drive failure.

That said, it doesn’t work on my macbook either, or on my husband’s PC. We get the IR reader working fine on all of them, so I don’t think that is the source of the problem.

I ordered the software and IR reader on September 5th, the day my pump arrived, since animas no longer includes the software by default. If they sent me the “old” version, I can’t imagine WHY that would have happened.

This is what my ezmanager max looks like… does your model list look like that? Mine says version 3.0.6

When I hit start.. this is what I get (I X'd out the middle of my serial #)

Obviously the IR reader is working if it gets my serial #... but it says it's not the right model and I can't do anything else.

Oh Sarah,
Mine also came without the ezManagerMax Software, on a Friday night late, so I have to wait until Monday to order it, sigh. Did you get your problems resolved with it? Have they improved the food Data Base from the older version? Are you able to put Breakfast, lunch & Dinner Categories in yet?
are you using it regularly for both insulin pump information as well as the Ping Remote BG readings?

Thanks for answering,

Site problem:

What set are you using? You might be reacting to the teflon canula and need to switch to a short needle set.

Tom, the site issue was resolved quite some time back… I switched to Apidra and everything got better. It seems I’ve developed an allergy to Novolog or something in it (I suspect the phenol - Apidra doesn’t have any). If I inject Novolog now, I get a similar reaction, it’s just smaller.

I can use metal or teflon sets with Apidra and I don’t notice much difference at all… I don’t have any site irritation with teflon sets. I do prefer the metal sets though because they heal much faster and don’t leave any marks. My favorites so far are the Orbit Micros with their 5.5mm 31g needle :slight_smile:

I’ve yet to have a site “fail” due to poor absorption with Apidra. My only site failures are of the adhesive failure variety… which has more to do with where on my body the set goes than which type.