Local omnilooping?

Dexcom share seems to be down, so my loop is showing black for the green circle and the next box over shows a dash with a yellow/orange circle. When you click that circle, it takes you to the G6 app which is getting data locally but not uploading to share.

Omnipod side has good coms and lets me bolus so that’s fine.

I seem to remember a way to configure loop to ignore share and to base everything off local readings?

What am I missing?

I’m on dev branch Loop v1.10.1 build Sun 10/20

I’m seeing BG data in TP, now, but not any in loop. Its not calculating dosages or anything. I have a red Loop icon and its throwing the ol’ “Share Error 1.”

If you want to get rid of share completely, I think you would have to delete the app and reinstall. But, try going into the phone ‘settings’ menu and turning off cellular data. I see a message that says “Turn off cellular data to restrict data to wifi, email…and push notifications.”

Ensure that the bluetooth setting is on.

This has worked for me in the past, but not tonight.

I don’t know if you are throwing a share error 1, like me. (Ive nver seen Loop turn black. This might have something to do with your different configuration). But, in the past, if I need to restore BT comm after internet went down and disrupted the system (share error 1), I just left the house and got out of an internet connected environment.

It would return to local BT automatically on its own. This is the easiest thing I can think of to try. Worked more reliably than the 1st crappy suggestion I had. I had a lot of downed internet this summer and this worked every time to get rid of that pesky, tenacious error.

I’m not going out there tonight to try it. Howling winds and heavy snow fall. I can hear coyotes out there. Scared of the wilderness.

I’m gonna try Laddies receiver suggestion and see if that works. Darn it. Its doing a 2 hour warm up on a sensor I’ve been wearing for 9 days…

Finally gave up and reconfigured xdrip on my Android.
At least now I have cgm data and can bolus on loop.

2 Likes

I gave up. I’m running off manual sugar readings. But, i just tested all my open loop settings, so I know everything will run smoothly off my manual settings. That was lucky timing!

1 Like

If you have Dexcom app running on your iPhone and you are receiving CGM data in the Dexcom app, you do not need Internet access to run Loop because Loop can get CGM data locally. In fact, that the most preferred and the most commonly used approach. Apparently some people are going through Share or other Internet-access based hoops, most of which do not work when Share servers are down. Katie addressed this in a recent post on the Looped FB group. Here is a copy:


1 Like

hmmm…my screen doesn’t look like this. Nor does it have this option under Dexcom Share. Puzzling.

@mohe0001, what do you see under Dexcom Share?

The devil, asking me to help him recruit followers. I refuse. But, he never stops asking.

Dev branch. Install date Oct 21st.

I just broke ethe sensor trying to establish communications its receiver. Its possible that if I use the receiver and put in a new sensor, this all goes away. I’ll try.

@mohe0001, these are the settings in the Dexcom app. The change needs to be done in the Loop app.

1 Like

Oh boy! I think I got it. Thanks you sooooo much.

@BradP, where are you at with this?

I had one heck of a time, but finally am back up and running.

From the various posts I’ve read, it is best to enable share on the Dex G6 app but NOT in the Loop app itself.

What took so long is that somewhere I read to uninstall / reinstall the G6 app, and for some stupid (explicative deleted) reason, Dexcom makes you sign in to even get the app up even if you don’t do share! WHY?

Fortunately, during the outage and when I deleted the app all I had to do was reconfigure the Xdrip+ on my Android phone and was able to have every function I needed except loop itself. I was able to bolus manually with loop so just lost closed loop.

It all appears to be working now though (knock on formica) so I’m back in closed loop.

This outage was WAY WAY WAY TOO LONG and totally unacceptable in my mind. I’m part of the Jaeb study, so they lost like what 3 days of data? What company doesn’t have redundancy on such an important system?

I’m getting data in Dexcom, but not in Loop. I got three hours of spotty CGM data since midnight last night. But, I’m fine with running open loop. I have been for weeks, now. So, no biggy. I think that I need to delete the whole installation and re-install without any inclusion of share. Share is murderous to the application.