Any Omnipod users experiencing a rash of failures lately?

It seems like I have gotten a problematic order of pods recently. I have been having all sorts of problems, from pods not completing the priming process to running out of insulin early to just plain failing prior to expiration. I have not experienced this rate of issues in several years. The Empty Reservoir issue has happened twice lately when I know there was insulin remaining, at least according to how much was in the pod earlier according to the indicator on my PGM. I’ve never experienced that before.

Have you called them to report? You should. That’s unusual for Omnipod. I actually don’t think that I have ever heard such a complaint before. Their engineers may want those Pods to look at. There could be serious safety implications for you.

Feels, offhand, like a manufacturing problem…not a software issue. I know that the pandemic has put stress on Dexcom to increase manufacturing in order to supply hospitals. I have not heard the same stressors put on Omnipod. Very interesting post…

I call on most of the errors, but not all because I have plenty of spare pods. I actually had another issue today with a new pod that did not beep after being filled. I did call about that one, and they are sending a replacement.

I think it’s certain batches. I had a heck of a time with a bunch not working well last spring. I also had a handful in the summer. I call most of them in, like you I don’t call all of them because it’s a pain and I get lazy about it. But I do make notes on them and call in 3 or 4 at once, that makes it a little easier.

1 Like

Does Omnipod ever not answer the phone? I just had a PDM failure and its been ringing for more than 40 min…there is no message. ???

@mohe0001 I hope you have gotten hold of them already but…

I never had that issue about no answer They pride themselves supposedly being there 24/7. When my PDM was acting out, they rushed delivered one to me.

This is the number I use 1-800-591-3455


This is silly, Marie. But, MM1 called an got through, so I re-dialed without the 1 in front and it went threw just like normal. I’m an idiot that cant use a cell phone correctly during times of panic.

1 Like

So usually I save up 3 pods at once to call in. I called in 5 at once dating back to August…They took all 5 just fine. I have taken to dating them, how many hours they were on and a couple of words explaining. Like, day 3 failure, next 3 hours in and numbers climbed, etc.

But I had let them pile up because it’s a pain to call them in…

So this was interesting. I put on a new pod and within seconds knocked it off. Weird because I usually have to peel them off of me.

So I pulled the insulin out of it and it still was “functioning fine”. And still saying it had over 50 units in it. Now sure you can’t pull all of it out but my caculations it only had at the most 5-10 units… So when does it say error??? Experiment time. So next I bent the cannula back and held it down and “gave” myself 2 units, still no error. Huh… Okay how about 4 units. The insulin is not coming out of it as I am holding the cannula tightly down. Still no error…Okay, pull the cannula out of the pod, it’s actually over an inch long or it stretched as I pulled it out and then “gave” myself 2 more units. Still no error.

I gave up lol and turned it off by the PDM… But that is a little scary how much it does not notice an occlusion.

1 Like