Crazy blood sugars since Tandem Tslim2

My blood sugars have gone crazy on Tandem T2 pump. On Medtronic pumps for years , but like the visual ease of Tandem display and wanted to start on Dexcom G6. Thought it would help get blood sugars consistent more with this…but NO! I dont get into high 200s unless ill…have had 300s and some 400s for NO reason and have even tested it like changes in BG with no food or same eating etx for three days but outcomes all over…really think its not dispensing insulin in a consistent manner. When called and questioned, I was told the pump would alarm me if there was a problem…well not if something was coming out, or being " bag" was being squeezed but not correctly. How accurate can that be. Anyone else having this prob??

1 Like

No problems here. Have you tried disconnecting the pump and doing a 5 unit bolus and see what comes out?

Similar infusion sets as what you used with medtronic?

I’m assuming you’ve checked your basal rates.

I just started tslim and not having these problems, but I did setup tslim with slightly higher basal rates.

One thing I noticed is that after tslim suspends, and resumes, then I might see a bigger rise than expected.

Are your highs after meals? Check your pump setting, and maybe adjust.

Have you used T;connect to download and review how the pump is changing basals?
Can use on computer or phone. I find it very helpful, and look at phone instead of pump to review.

I just moved from Medtronic to Tslim Control IQ.

Had a real problem with the infusion set and especially filling the cartridge. After several changes and high BG I determined I was not getting all the air/bubbles out. I used to look at youtube and copy what they were doing but most people make mistakes. I then followed Tandems instructions step by step. There were steps in there that I missed. Since then I have had 4 perfect site changes and have not been out of range. Sounds too simple but I’m sure that was my problem.

1 Like

It’s actually extremely accurate. Tandem has shared the accuracy data with everyone, but unfortunately I was never able to find accuracy data for Medtronic pumps to compare it to. Check out page 308 in your owners manual.

Over the years, I’ve seen many people share that they had to adjust their pump settings since moving to Tandem, that they simply couldn’t transfer them exactly. You learned how to optimize your settings to work in your Medtronic pump(s), but it doesn’t mean that those values that worked for you were “true”, just that they were adjusts you made to optimize how the pump(s) worked for you. You’ll probably have to make a few tweaks to the settings to make the X2 work great Maybe try a few weeks without automation to see where you basal needs adjusted?

@Amom2go:

You have already gotten some good suggestions from @Jim26 and @rcarli for checking that the pump is pumping and that the tubing is properly filled. In my experience, each “pulse” of the tubing fill registers about 0.3-0.4 units and moved the liquid about 1” each time along the length of the tubing. If you are using 23” tubing, I find that it takes 12-13 units to fill the t:lock connector and the tubing.

Is this your first infusion set with the t:slim or have you used several?

Every once in a while (like 1-2 times out of 100), my infusion set (I use autosoft 90), will not leave the Teflon tubing in my skin and it will be folded across my belly (rather than in it) underneath the adhesive. As a result, insulin is getting happily pumped with no alarms, but none of it is going into me so BS skyrockets. In that case, you can apply a new infusion set and then do a “Load” where you only select “Fill canula” with the existing cartridge and already filled tubing. That of course assumes that your cartridge and tubing are properly filled … which may or may not be true for you right now … but it will only use 0.3 U. That may be another thing to check.

Best of luck resolving this issue … and stay safe.

John

Everyone has given great ideas. One possible idea, are your pump settings correct? One of my concerns is all pump data entries must be hand entered.

If anyone must replace a pump for warranty reasons, the pump settings should be able to be entered from a pump settings backup, not by hand where transcription errors are highly possible.

Best wishes. Keep us informed.

I’ve had it stop randomly when I’ve had a blood sugar of 138…and it was not a “going down” pattern. I’ve had quite a few notices of boluses not being completely delivered and that’s driving me nuts because when I look for any reason as to why,I can’t find anything.

You get that notice when you accidentally hit the “bolus” button when putting your pump away. If you get in the habit of turning your screen off before you stuff the pump in you pocket, waistband, or wherever it lives… you won’t get that warning anymore.

You could also adjust your screen timeout yo be shorter, but I personally find that more annoying than just turning the screen off.

I have had this happen too, but since getting suggestion to twirl needle covering before removing, it hasn’t happened again.

The other problem I had with unexpected high BGs was resolved by switching to 9mm infusion sets. Previous 6mm Medtronic Quicksets worked fine, but with tandem, need the 9 mm sets.