New to OMNIPOD , 2nd pod after starting first one with trainer, cannula not deployed!

I started changing a POD as per schedule but had to go through so much frustration. I wasted 3 pods but Canulla did not insert.

  1. Was I doing something wrong!!? (I did exactly as per the instructions…)

  2. I heard some Lot have issue, then how come the one with trainer worked fine? So kept looking for flaw until got tired and gave up after third. Had a little high BG at time of changing, so was hard to keep patience.

  3. After almost half day after getting back to pen, when I felt a little better, what I found from the one that worked is Lot # are same but has serial number started with 03 and failed one has 04 , so i found one that has serial # started with 03 and Canulla inserted!!.

Dont have to mention that obviously they will change those pods (but what about insulin gone!). Just for first week this is a confidence looser!

Did any one face the same issues ?!appreciate in advance or any insight to make it work better.

I totally understand your frustration!! My son started using the OmniPod system nearly nine years ago when he was four and we definitely had trouble in that first week or two just trying to figure things out.

Firstly, here is a list of the lot numbers that were recalled.

Secondly, try (and I know it’s hard) not to get too discouraged. Know that what you are experiencing is not uncommon. My son set the alarm off of one of his first Pods after banging his tushie (the cheek with the Pod on it) against a door in his effort to keep his brother out of a room. We had trouble just finding the right locations for his body that worked without the cannula bending. With the slimmer profile Pods, that particular problem is not as much of an issue, and assuming you are bigger than a four year old, you’re not likely to have those problems either.

You kind of get into a groove after a few changes and it all becomes rote. We truly very rarely have Pod errors of any kind. There is an occasional one, but it is rare.

Good luck and hang in there!

They will replace your lost insulin, but they make you write a hand written letter detailing how much you lost. I think by doing that, they figure most people will give up. You can suck the insulin back out of the pod the same way you inserted it.

1 Like

Thanks Lorraine , it was roller coaster so far , was so excited and really liked the first one also. Got better results but this was pain full particularly on weekday to spend this much time, But i like result so far with it so will hang in there and i m 33 so finding a spot was not an issue , glad to hear your experience is better after first few weeks!

1 Like

I think i have to try that, but reps that i talked to didnt mentioned any such thing , only thing he has to say is sorry when i complained about lost insulin sounds like they didnt want to go there until some one figures that out own their own, i will write them letter and will try to take insulin back from POD also before I return those old one.

Appreciate you suggestion thanks.

@Ndesai Wondering how you are faring with the pod now. Is your experience going more smoothly? My personal practice regarding insulin is that I will take it out of a failed pod in the first 24 hours or so. Beyond that, I just use fresh.

I use the same cut-off time, 24 hours. Past that, and I won’t suck out the remaining insulin to re-use. Although I suspect the insulin is likely still potent well past this 24-hour period, 24 hours just seems like a nice arbitrary number…