Recent problems filling pods

Anyone having problems filling pods with insulin recently? I just opened a new box of pods and was unable to fill the first 3 pods with insulin. After inserting the syringe in the pod, I was unable to push the plunger down. Even using excessive force and trying to reposition the needle did not help. I was finally able to get insulin in the third one, but the double beep sounded really weird and then my son's BG went up to 400 within a couple of hours. I probably shouldn't have used the pod, but now I'm wondering if I should skip the whole box/lot and move on to another box.

That has happened to me on a few occosians. I never skipped the entire box. Usually most of them would still work. I had a lot of random pods that beeped weird. I never noticed that affecting their quality. But who knows, I had so many problems with the OmniPod.

If it's difficult to fill a pod call Omnipod and tell them and they'll replace that pod. Kinda a pain 'cause you have to keep extras with you when you're out but they are good about replacing the ones that concern us.

That's happened to me a few times. I know Insulet advises against this, but I just muscle the insulin in and proceed. I've never isolated that as a particular problem that keeps the pod from working properly.

I've also had pods give wierd, even sickly beeps. Thos have never stopped the pod from working other.

OTOH, I've had pods that filled easily, sounded great, primed fine, then failed miserably for some unknown reason. If they work, they work and I've kinda stopped worrying about the details. I'm pretty confident in the Omnipod system, and with a few exceptions, the pods work well enough under any number of circumstances that Insulet would say were reasons for tossing one.

It seems to happen to me about 20% (1-2 out of a box) of the time. When I feel the resistance I usually pull it out and put it right back in and try again. It usually works right away. Maybe the first insert was too much of an angle. If I still feel resistance I back it out just a little bit and then try to depress the plunger. That usually does the trick. I've wondered if maybe there were a little too much air bubbles in there, so backing the needle out a bit allowed the air to escape. Just a guess. Those tips work most of the time. I can only remember having to discard one pod over the last year or so because of that problem.

I have had the same problem. I would suggest not using the ones that don’t activate. I had an error rate of 20% on the 30 that I get sent. I suggested that I should just have them replaced. That didn’t go down to well. However the next batch have been great. I just got a bad lot. My personal thoughts are not to take chances.

I just had the same exact problem, I tried to force it, and pulled it out and stuck it back in a few times, but it wouldn't work. Sometimes you can't push the plunger too smoothly, but this was different.

You're not crazy. I have noticed this as a recent problem in the last few months. I just call Insulet every time to let them know there is an issue, and the pods are replaced.

I just got off the phone with Insulet for the second time this week because of this problem. Last night I tried changing my Pod and two in a row failed to let me load them. This is the fifth or sixth time this has happened to me in the last month. Gr-r-r! I even had a half-box that I sent back to them and they replaced. (Don't bother, folks. The replacement pods they sent me were no better than the box I sent back to them, and sending it back was a hassle.) I just tossed the first two this month, but now I am starting to turn them all in for replacement. I cannot afford to keep tossing Pods. At least I am not wasting insulin since none is going into the Pod. I also forced a couple by pulling back on the needle, but some insulin leaked out of the fill port, so I ended up having to change both of those Pods early.

One service rep told me, "Well, I hope that when the new smaller Pods come out, this problem will be solved." I did not have the nerve to ask him WHEN the promised smaller Pods would be available.

Don't get me wrong. I love the Pod and the freedom that it gives me. All systems have their problems and their drawbacks, but this is obviously a recurring problem and I find it frustrating that Insulet is not taking proactive steps to not send out defective products.

I just had this happen. Every pod change I was burning through 2 or 3 pods trying to find one that would fill. I called CS with each pod change and they replaced each one. The 3rd time, I told the rep that this was a little ridiculous. He looked at my call history and saw the issue. He told me to stop using the pods from that box. He replaced the entire box and requested that send the rest back to them. I would be sure to call in each one in a timely manner so that they can track the issue. They were super helpful in my case! The good news is the next box had none of those issue :)

wow. very interesting as Ive never once had this happen to me in 2 years of podding!

we've had the occasional one be hard to fill, but just usually I'll pull the syringe out and reinsert and it injects easily with out resistance. I've had some weird non beepers lately but they've always replaced them.

I've had some that I've had to press the plunger pretty hard, but it has never stopped me from filling a pod. I've never tried to reposition the needle because I have always eventually gotting the pod to load. As far as I know, it's never created a problem once the pod was filled.