T:slim X2 charges, but won’t upload data, on USB port

TuDiabetes Community:

My Tandem t:slim X2 (which is also my G6 receiver) continues to charge properly on the USB port, but seems to no longer upload data to Tidepool over the USB connector.

Has anyone countered this? Do you have a fix?

I will call Tandem Technical Support tomorrow, but figure I may get more useful information here. I fear my pump is no longer under warranty and had hoped that it would last until the t:sport was available, but alas …

Fortunately I can see all my data on t:connect … but my endo prefers that I upload to Tidepool.

Any tips or tricks trying to clean the USB connector that won’t make matters worse?

Thanks for your consideration.


Not all USB cables are created equal. Some can transfer data, but the cheaper ones can’t. They only charge. Keep trying with different cables around the house. The one that came with the T-slim will work. A USB cable that came packaged with a cell phone should work, too.

If all else fails, you can buy a new one. You just need to read the packaging and verify that it can transfer data.



Thanks! While I don’t keep my cables sorted as charge-only vs data, I have now tried 6 different cables … and I’m pretty sure that I’ve used at least a couple them in the past for data upload.

That said, I will try to test several additional cables.



On possibility, John, is dust in the port. Try blowing it out with canned air. If that doesn’t do the trick the data contacts may be damaged.

Also the problem may be with the port on the device running Tidepool.

Micro USB has 5 contacts - 1 & 5 are 5VDC and Ground, 2 & 3 are for data and 4 is not connected or is used for an optional reason.
This link might be helpful,

1 Like

I would be more likely to contact Tidepool support than Tandem support. They are usually quite helpful and I don’t think Tandem will be concerned with your problems downloading to Tidepool.

1 Like

Have you tried uploading not to Tidepool but to t:connect using a USB cable connecting your pump to your computer?

I have no idea whether or not Tandem would be concerned about problems uploading to Tidepool. However, if you cannot use Tandem’s t:connect uploader program to send data via USB to your t:connect account, then you will be reporting a problem with Tandem’s tools.

I think Tandem would be much more likely to show an interest in your problem if it is a problem with Tandem tools.

If you do not have the t:connect uploader installed on your computer, the links below to a Tandem web site help page may help.
How do I install the t:connect uploader software on my computer?
How do I upload pump or BG meter data to my t:connect account using my computer?

Thank you all for your suggestions. While I have not yet been able to upload with the USB cable, I’ve gleaned something from each of your suggestions.

Thus far I have:

Purchased and used a new micro-USB cable rated for data use.

Tried to clean the pump connector with a bit of non-conductive isopropyl alcohol and both an old toothbrush and a GUM dental probe.

Downloaded and tried the latest t:connect uploader.

Learned from Tidepool how to check the windows device manager to see if a new device appears under COM/LPT when I plug in the pump.

Tomorrow morning, when IOB will be zero and I need to change a cartridge, I’m going to try a full power down and reboot.

There is good news: the t:connect phone app uploads data automagically from my phone to t:connect (even though my endo prefers Tidepool).

And, when it is time for a new pump, I can legitimately tell Medicare that my current pump has a problem … although I had hoped that the X2 would last until the t:sport is available.

Thanks for all of your suggestions.


1 Like