Tandem X2 spontaneous low battery

I’ve had this happen to me about 3x now so far over the last year or two. I’m wondering if anyone else has had this issue. I plug the pump into my computer to upload my history, finish the upload, and then unplug the pump. The uploader (I use both tconnect and Tidepool to upload, usually one right after the other) may or may not still be running but I unplug the pump and I get a loud beep/alert from the pump and the screen is saying that the battery is very low (5%). When I plugged it in 5 minutes prior the battery was at 85% or better. I usually never let it go below 60% and charge while showering every day. If I plug into a power source I’ll get the charging lightning bolt and it will stay at 5% and not go up. As soon as I unplug it I get the alerts again. I’ve also gotten error messages saying the charging source is not capable of charging the device, which it has worked fine in the past. I have pretty much used the same cable (not the Tandem supplied cable) forever. I’ve switched to other cables (including the Tandem cable) and other chargers. No luck. This has happened on both a Macbook and Windows computer, and the first time I think it wasn’t a computer just a charger cause I lost 3 or more days of data. I work in IT so usually the first thing after trying all possible options is reboot the device. Which I’ve done for each instance. I rebooted today, came up still at 5%, plugged it in and it got to 10%. Unplugged and plugged in elsewhere and then the next time I looked at it (~10 minutes later) the battery said 100% charged. I unplugged and it stayed that way and hopefully is back to normal. Not sure if this has happened when I’ve disconnected at the pump end first or the computer/charger end first. I have called Tandem on this in the past and will again. The last time I had rebooted the pump before calling them. They suggested I should have called first and they could have walked through diagnostics, etc. One of the times (might have been the first time), it was like the pump froze completely. Screens would not update and some stuff wouldn’t respond. Anyone else have experiences like this?

II’ve not had this exact problem myself, but my first warranty replacement (I’m on #3 now) was because of the battery. It wasn’t even why I was calling, but I was told then that if it loses more than half it’s charge in 3 days, it needs replaced.

I’ve always found their customer service great. They send you whatever you need so long as you go through their troubleshooting steps. Just call them right away without trying to fix anything yourself. Make you you upload your data after the battery drain, though, so they can clearly see it.

Thanks, but that’s the thing I don’t think it was a battery issue. I think it was a hardware/software issue incorrectly reporting that the battery was low. I know it will charge fast but it will not go from 5%/10% to 100% in 10 minutes, if the battery was really only 5% charged.

Very true. But still, it’s a medical device. Even a software glitch should necessitate a replacement.

My cell phone does that sometimes.

I have had the experience Rick described. Happened twice. Exactly the same.

David, did you call Tandem when it happened? Did they tell you anything? Glad to know I’m not alone but not glad its happening to others too.

Yes, I called Tandem, at least the first time. Their solution was to re-boot, which is the solution to problems with so many modern devices.
I just checked the User Manual, and they do not tell you how to re-boot. Hook the pump to a power source with the USB cable. Hold down the Screen On/Quick Bolus button for 30 seconds. The pump will beep 3 times before shutting down. To re-start, repeat the process of plugging into a power source and holding down the Screen On/Quick Bolus button.

Yup. Reboot solves lots of issues. I googled on powering off the pump when it happened the first time. It powered off ok. The power on was a little nerve racking because the bit about turning it back on having to hold it down was missing or not part of the shutoff note I found. :slight_smile: I’ve gotten to the point where I plug the cable into the pump and then into the USB port. Used to do it the other way, same for unplug and that was always when it froze or crashed or whatever, in the unplugging process from the pump. I always wonder if the port on the pump was flakey.

1 Like

I had this happen only once. I had a long conversation with a Tandem tech support guy who was very helpful. He told me that if you charge a t:slim with a charger of insufficient wattage output, this was the result. He had me plug the pump in to a higher-wattage charger for about 15 minutes, the unplug ut to see the result. And the result was that it worked just right.

So, the summary he gave me was:

  • iPhone charger = doesn’t work
  • iPad charger = works fine
  • computer USB port (most) = works
  • computer USB port that can/will trickle charge = probably will cause the error intermittently, especially if the pump is plugged in longer than required to just take it to 100%

I use an old iGo travel charger from my working days (if anybody remembers those things) and it works great.

1 Like

Thanks. That is helpful. I’ve gotten into the habit of charging with a usb portable charger instead of a wall charger, plus I always use the tandem cable now. Ordered 2 more to have on hand. I also unplug from the power supply instead of unplugging from the pump first. Most of these are probably me just being paranoid but so far so good. If I plugin to an electrical outlet I use the tandem charger now, but I have iPad chargers and charging stations that have the higher wattage too. The plug into a different charger for at least 15 minutes is something I’ll keep in mind. I always wonder if the USB2 vs USB3 ports on the computer could affect it too.

Hi Rick- When I was on a Tandem G4, I did have the exact same thing happen a few times when I was uploading data to the computer, and then unplugged the pump.

Support told me that when plugged into the computer, the pump’s CPU goes to a high power state and pulls a lot of power to upload data. He didn’t come right out and say it, but it sounded like the battery in the pump wasn’t really enough to support the CPU unless it was at 100% charge. My battery would recover once the CPU went back to a low power state, but it would take 5 or 10 minutes.

My solution was to leave the pump plugged into the computer after downloading for 5 or 10 minutes, and it never happened again.

Thanks. I’ve been charging for about 15’ every day around the same time but this is good to know for future uploads.