Correct steps to start new G6 and new xmtr on pump, tandem iPhone app and Dexcom iPhone app

I use a tandem Tslim pump and the Dexcom G6 sensor. I use the tandem iPhone app and I also use the Dexcom iPhone app. I do not use either company’s receiver.

I’m stumped. I always mess up the process of starting a new G6 and a new xmtr because I use both the tandem iPhone app and the Dexcom iPhone app and both of them need the new xmtr code and I never know which device’s app to enter the code in.

Tonight, I did these steps in this order and it didn’t seem to work like I thought it would.

  1. Insert new G6.
  2. Insert new Dexcom xmtr (I had gotten a msg on the Dexcom app saying I needed to insert the new xmtr.)
  3. Enter the new Dexcom xmtr # on the Dexcom iPhone app.
  4. Tap Pair when it appeared on the Dexcom iPhone app.
  5. Tap Start Sensor on the Tandem pump (not on the Tandem iPhone app).
  6. The pump asked for the new sensor code so I entered that on the pump.
  7. The pump did not ask for the new xmtr code! So I tapped Start Sensor on the pump.

The usual two hour clocks appeared on each app.

I’m still in the two hour warmup as I write this.

The new xmtr number appears in the Dexcom app settings as it should but the pump still displays the old xmtr number. Also, on the pump, under My CGM, the Transmitter ID Lise, where I’m supposed to be able to enter the new xmtrnumber, is grayed out! So at the moment I have no way to tell the pump the new xmtr number!

On my phone, Bluetooth is on and I’m paired with my pump but I cannot pair the new xmtr.

Oh, by the way! I’ve been on hold with Tandem tech support for nearly an hour now, suffering the absolute worst “music” I’ve ever heard, which is why I’m writing to you all cuz I’ll bet I’ll get good answers faster here than there!

All offers of help and advice and specific steps in specific order will be gratefully appreciated!

I don’t know how to correct your current issue but here’s how I start a new transmitter.

  1. Apply new sensor
  2. Input new tx # into the pump
  3. Start sensor on pump
  4. click through the steps to start a new tx on the dexcom app

The app should sync right up with the pump sensor session. I’ve been using this order of steps since getting the T-slim 3 years ago and it has always worked.

Assume you’ve been helped by now. But you need to stop the sensor session on your pump because with the wrong transmitter ID you are not connected to the current sensor. Once you stop the sensor session you will be able to enter the new transmitter number. Once you do that, start the new sensor with No Code since it will pick up the code from the sensor already working with your phone.

Ain’t technology grand?

I never did get a human on the phone last night with Tandem tech support, but that’s a different topic. But about an hour into the warmup, I got a new msg on the pump telling me my xmtr ID was wrong. Big surprise. At that point, but not until then, the xmtr ID line in my CGM settings options was NOT grayed out so then I entered the new ID, restarted the sensor, calibrated it twice on both pump and sensor apps, since I had never entered the sensor code, and once the normal two hour ear up finished, I’m good to go. Don’t ask me what happened!

But thanks for the help you all gave me.

Tom, this also applies to your other topic about starting with no code, do not switch devices in the middle of starting a new dexcom sensor. If you start the process in the dexcom app get all the way to the warmup counter before telling the pump about the new sensor/transmitter. If you start the process on the pump finish it on the pump before telling the dexcom app about the new transmitter.

Thank you, all. Esp the part about. It switching btwn devices. I’m sure I didn’t do that right.