Hacking the Omnipod 5 - lowering glucose target

I’ve recently upgraded to the Omnipod 5, and have been using Omnipods successfully for at least the last 8 years. The 5 is almost everything I’ve been looking for. The algorithm works and I’m truly impressed…except for one thing. You cannot enter a target glucose for automatic mode lower than 110. This is clearly a CYA pushed by their lawyers. I was wondering if anyone has developed a hack yet that allows you to set it lower? Ideally, I’d love to set it at 85

2 Likes

I’ve also been satisfied with it but I have no hack. Workaround is needed for the bolus calculator…it also uses a goal of 110 for meal bolus and corrections. The need for workarounds has me in manual mode about 20% of the time.

1 Like

I’m hoping that minimum target rate will come down as the FDA sees how this works in real life. I blame the FDA and not company lawyers for the restriction. It was a concession likely made to get the product to market.

This is with a G6 CGM, yes? Can you abuse the G6 “calibration” function to make the G6 think that a real 85 is “read out as” 110?

That way when you aim for 110 on CGM, you are really aiming for 85 in real life.

Fair point, Jim. I wouldn’t be surprised if that were the case either

Brilliant suggestion. Great example of how sometimes the most complex problems can be solved with the simplest solution. I recalibrated it this morning, and it seems to be holding. I’m not sure if it will eventually come back to the original true value, but we’ll see. The one way I know for sure you can get the calibration to hold is if you insert a new G6 sensor and do not enter the code. The downside is it will ask you to re-calibrate twice a day, just like the old G5

It’s required twice on the 1st day, and then only required once every 24 hours after the first day.

But the number will keep creeping back toward what the Dex believes to be your real BG. So you will have to keep re-calibrating on occasion to keep it lower than your BG really is. The calibrations don’t “stick”.

1 Like

Got it Eric. Thanks for clarifying. Yes, that’s my suspicion it will creep back to my real BG. I’ll try calibrating in both modes - with and without code - and see which one holds longer

1 Like

I always use the calibration method because I get better results that way. I test my BG a million times anyway, so I figure I might as well put in the number every once-in-a-while.

Non-calibration and using the code has always given me inaccurate numbers.

2 Likes

So an update - @Tim12, your hack worked out brilliantly. I re-calibrated my Dexcom twice in the first 24 hours, and it consistently displayed 20-30 points above my actual levels through the remaining sensor period. In fact, that delta has held through a sensor switch after my last one expired. It still takes a little getting used to, seeing my BG displayed ~25pts higher than what it actually is, but it’s working in fooling the omnipod, and resulting in my basal levels holding between an actual level of 80-90

3 Likes

Glad to hear the hack works! I can’t claim full credit because the idea is plainly stolen from the Monty Python “Mattress sketch” :slight_smile: https://www.dailymotion.com/video/x6qglfb

If you get enough experience with forced Dexcom calibrations, maybe you can answer a question of mine: does setting it to read 80 as 110, just cause an additive offset of 30, or is more accurately a multiplicative factor of 110 divided by 80?

That sketch is hilarious. I’ll be using those lines at my next Endo appointment. “You see - when it shows 110, you have to subtract 20…”

So far, it seems to be an additive offset, but if that changes, I’ll post an update to let you know

1 Like

Don’t blame Insulet’s lawyers; blame the FDA and other regulatory authorities who demand this stuff.

I wouldn’t be surprised if it came from either their lawyers or the FDA. Would you know if other systems also have the lowest target limit you can set at 110? Regardless, calibrating 20pts higher than actual is working brilliantly and holding

2 Likes

Glad to hear that it worked…Thanks for being a trailblazer!