G5 iPhone users - how to make iPhone to only display/sound Dexcom alerts?

So iPhone has this great feature - Do not Disturb - but, of course, if you have a Dexcom app on your phone, you want it to disturb you any time! That is the whole point.

Dexcom specifically says that in order to receive audible alerts, DnD mode has to be off. Well, that sucks. Now you get any random email or text notifications, instead of just Dexcom alerts. Who needs that.

Any idea how to work around that? Manually turn off email and text notifications before bed?

Anyone tried to jail-break their iPhone to install any unofficial apps that do what we want?

I put my phone in flight mode but activate the bluetooth manually. This means no calls, no emails etc, but you will receive the Dexcom alerts.
It is anyhow not good to have a phone connected to all network next to your head while sleeping.

That is a great idea! I will try!

Thanks for the tip. I didn’t think of that.