I want to turn off some of the notifications from my Dexcom G6

On the tenth day of a sensor session I receive a notification that my session is about to end 24 hours, 6 hours, 2 hours (?), and 30 minutes prior to the end of the sensor session.

The 24 hour notification is fine, but the rest often interrupts my sleep (I wear my Apple Watch to bed). Is there any way I can turn these notifications off?

I try to start my sessions to time the notifications to happen during daytime, but sometimes sensors fail and it´s not up to me when I start a new sensor session.

Anyone?

You can turn off everything except the low under 55 alarm.
Do it in the dexcom ap.

1 Like

I know I can turn off notifications, but I want and need the noftications. I want to turn off only the ones who reminds me that the session is about to end.

Is that possible?

No.

The only work around is to put your watch on DND mode

Or, if you’re an Android user, you can use the Xdrip+ app instead. You only get the notifications you set up with Xdrip.

https://xdrip.readthedocs.io/en/latest/

3 Likes

My answer: I change my Dexcom at 10 PM
Travel can make this weird
I’m looking forward to the D7 that will: give an extra 12 hrs “grace” and
Only have 30 minutes warm up
I know this doesn’t really answer your question.
But I started with morning site change and was similarly bothered!

You can go to apps on your watch in wear app on phone. Go down to where it says dexcom and slide the bar to receive no notifications on watch when you sleep. I also set some alerts to vibrate at night.

I am not sure about that, as people said I think you can turn off everything except the dreaded 55 low, but maybe not selectively for that one. You could turn your watch off overnight and only charge it.

Well the thing is, you might actually want to have the low or high notifications!!
Just not the useless reminders.

@Jimi63: What is DND mode?

@Robyn_H: I have an iPhone and an Apple Watch.

@MBW:

I know that is a fix, but as I wrote this is not always doable for me. More often than not my sensors quit before ten days are up. So it´s kind of not up to me to decide when a new sensor is started.

@Christa1:

I don´t use the “Wear App” on my iPhone. Are the settings different from the app “Apple Watch” that I use? I do not get any options there other than “do as phone”.

And I do want notfications for high and low when I sleep. Does “Wear App” offer other options than the app “Apple Watch” for iPhone?

@meee:

I know but I wear my watch to bed because of the high and low alerts, so that would defeat the purpose.

One fix is off course to turn off all notifications before bedtime every time I get the 24 hour notification and turn notifications back on in the morning.

@Siri DND mode = Do Not Disturb mode on the Apple watch

1 Like

I guess try that then. I thought you said the alarms were bothering you so I don’t know- it’s up to you to figure out what you need to do. I don’t even wake up for alarms- I have my phone and the Dexcom receiver alarming me- when I wake up very low it’s just because my body wakes me up.

I think sometimes they stop me from going to sleep- there was one point I turned off my phone for quite a while- my father was following me at the time and he was upset about that. I just couldn’t stand all the alarms anymore, most of them are useless. The one that really helps is the one that tells you you’re gonna go low in 15 minutes.

The best lows for me are when I wake up in the 30s, because I don’t even feel stressed or that anxious, I just feel it, drink some juice and go back to sleep or maybe it’s time to get up so I just wait there until I recover.

@meee

Just a misunderstanding. I wondered if it was possible to turn off only the the notifcations reminding me it was soon end of sensor session, not how to turn of all of the notifcations and alarms.

I have an alarm I can’t find info on anywhere. (tslim) I get wakened between 6 and 6:30 am on some mornings with a statement like: A high BG was entered 7.3 hours ago. Test your BG.
In the meantime, my graph has been flatlined normal all the hours I have been asleep. And wanted to keep sleeping.
This has happened 4 or 5 times in the past month. I don’t know what I did to cause it to start happening. I have silenced as many alarms as I can but I need the low and high alarms. Tho I just learned yesterday to put them on vibrate for a meeting. Now if I can just find that to take them off vibrate! The Medtronic is so much more intuitive on how to deal with alarm changes… to me.

In “Options”,“my pump”, “alerts & reminders”, “pump reminders”, “high BG” turn off the slider, check mark, you should see setting saved.

I.left my low BG reminder on however, for 10 minutes. That’s a critical additional safety measure.

I get alerts from my phone anyway. And am generally aware where my glucose is during the day.

Thanks, MBW. i had had the high alert turned off but since the pump was not very active on lowering my bg at higher numbers, I turned it on again. I get busy in meetings and don’t want to keep checking it. However, I guess I need to turn it off again. Thanks. I have another one I’ll save for a pros and cons thingie I am saving up. This pump is not as great as I thought it would be in attention needs compared to Medtronic. Pumps are all like carrying a toddler around 24/7 I guess!

1 Like

Maybe someone knows how to turn off the “lost connection” alert? I only get that alert at night, and it causes the pump to vibrate, which is almost enough to make me not want to wear the pump at all.
It finds the Dexcom again and there aren’t any interruptions on my CGM tracing on the pump do it’s clearly short lived but enough to wake me up.
But I can’t find it in the settings.
Anyone?

@MBW
Dexcom-app → settings → alerts → signal loss → off

Thanks! It was the pump and not the phone I was trying to silence but your answer guided me in the right direction. What I did was increase from 20 minutes to 45 minutes loss of connection before I get an alarm. We will see how that goes.

I turned off everything in the phone app yesterday but then found it was better to put everything to vibrate which you can do for nearly all except the 55 alert- for that I figured out that I could change the sound to a softer ding which is much less annoying. Somehow by doing all of this I’m not getting the horrible new loud trill beep I think now on my watch too.

But to use the phone app at all now dexcom has forced you to allow the critical alert.