Metronic insulin pump A33 Error

My brother is getting error A33 on his metronic insulin pump, what does this mean?

You need to call their helpline, that means the pump is malfunctioning. you might want to call your doctor too, so you can make a plan until they can send you a new pump. deep breaths!

I was not able to find anything specific about an A33 by Googling Medtronic’s site. I just stumble upon this other really old post about the error from 2008 on TuDiabetes.

The US number for contacting Medtronic support is 1.800.646.4633.

At the moment I believe their phone menu is to first press “1” for product support and then press 1 again for insulin pump support. The phone system will then request the full date of birth of the person who owns the pump in MM DD YYYY format and then the five digit zip code of their address on record with Medtronic.

When you talk with a support rep they will also ask for the serial number of the pump. And heck, they may also ask what your most recent Blood Glucose (BG) value was. (I think it’s in their script).

If the pump is still under warranty then Medtronic will ship out a replacement. However it probably won’t show up until Monday morning because UPS & FedEx don’t deliver on the weekend. But perhaps Medtronic expedite in some way? Only way to find out is to call the help line and talk to a support rep.

thanks for posting the phone number, I was hoping someone would. and all the other details of what they will ask. I just remember that old discussion because since I started pumping over 25 years ago, I’ve never had to think of a backup plan since I’ve always had 2 pumps, and because it was @askmanny who wrote it.

@Brandie2 when you get a chance, I’d love to know how your brother is doing.

[quote=“Brandie2, post:1, topic:48967, full:true”]
My brother is getting error A33 on his metronic insulin pump, what does this mean?
[/quote]That is a safety check alarm and to resolve it Press SEL, then ACT. and do call Medtronic.

I had this error today. The pump (Medtronic Paradigm) offered me the option to reset - which I did, but still the error. I phoned them and they are sending a replacement ( you will need one as this is a genuine fault).

I did find a temporary workaround though. At the back end of the plunger tube there is a plastic cap. If you have the error, it will probably be protruding a little.

As you fill the pump, push it in, and hold it there while you fill your cannula. The pump sensor should then work and detect that the cannula is nearly full as it usually does, without spraying insulin everywhere, and all should work as normal thereafter.

As with any advice though - TRY THIS ENTIRELY AT YOUR OWN RISK - it worked for me - good luck!

This sounds like a recall issue with Medtronic’s pumps. Follow this LINK for the recall notice from Medtronic, if you have this problem Medtronic instructs that you stop using the pump and call them for replacement. They strongly advise to not push the cap back in while the pump is connected to your body because you may experience an unintended insulin delivery.

I would only hold it down whilst filling the cannula, while the pump is off the body - I hoped I’d made that clear in the post but apparently not. As a type 1 I didn’t want to be without the pump and relying on messing about with jabs etc. so I used the workaround for 24 hours whilst they got me another pump - and once I’d persuaded the pump to let me fill it, it worked just fine. But s I said in my original post - use this method at your own risk - it worked for me and it might help someone else…

I have the same problem that is stated before me and i was wondering on how to proceed in this case.
I have the same insulin pump for about 9 years now and i did not have an issue with it in all that period, does anyone know if i can replace my pump or do i have to get a new one with money out of my pockets.
Thank you

  1. Read your manual / user guide and see if you can find this error listed with suggestions what to do.
  2. Call your local Medtronic trainer / representative or endocrinologist (whoever originally explained to you how to use the pump).
  3. Try to contact Medtronic on social media (though this really should be a last resort if nobody locally can help you).

I know this topic is old, but I got A33 today and found a link on the Looping get hub and fixed my Paradigm 722 pump. I wanted to post this so others can find how to fix their pump.
The motor cap was pushed out (I dropped the pump a few days ago and it hit the tile floor). Remove the reservoir and you can push the cap back in. It is now working!
Link is below:

Nice fix! Thanks for posting the links and reminder.

Readers should be aware that just pushing this motor cap back into position without the process that @Ed_stanford describes, including personally disconnecting from the pump, could result in a very large unintended infusion of insulin. This was a significant recall issue that Minimed addressed many years ago.