Pump stuck on prime/rewind


#1

Any ideas? I’ve spent now about 30 mins total trying to get through to the US minimed tech support as the tech support here in Finland is closed on the weekends (typical for Finland).

Anyway I can’t get to the main menu. It has me rewind as usual, but when I try to prime it just says disconnect and keeps priming without showing how much insulin i’ve primed it with. I replaced the battery, but it doesn’t matter. So now my daughter has been without the pump for 5 hours. We use the un-tethered method so she does have lantus. I guess I will increase her basal lantus to get us through till tomorrow. I’m just so frustrated right now with the lack of help and resources on the weekend for something like this!


#2

That happened to my four year old pump and it meant it was time for a new one.

Did you get through to Minimed? They shipped a loaner out to me me the next day.

Hope things are okay.


#3

Dial the American country code and see if you can use the 1800 MINIMED. They are open 24 hours a day in California. Have you tried taking the battery out?


#4

Yes I’ve tried the battery and replaced with a new one. I can’t dial a 1-800 from over here but keep trying the number that is on the back of the pump. I’ve gotten through to tech support before with it.

However this time I can’t get through, just the “we are currently experiencing a high number of calls” ect ect.

Gonna try to go to our nurses office by 8am and see if we can get a loaner from her. And my husband will call the minimed office here today as soon as they open.

This is the 3rd minimed pump that we have had in the 3 years of pumping and this one is only about a year old!


#5

Did you get through to Minimed?


#6

Not to the US one no. I tried again this morning 6am my time. We got the demo pump from the nurses office. The nurse called one of the reps on her cell phone this morning before she was in the office and she took our info. We’ll get a new one in the mail tomorrow. But I still want to switch off Minimed. I’m just tired of this run around. The Spirit is available and even though I’ve read some unfavorable reviews on it, at least they have tech support here on the weekends and available backups that we could get from the hospital anytime even on weekends.


#7

What was the result with this, Amber?

By any chance did you ever get an A33 error?
http://tudiabetes.com/xn/detail/583967:Topic:44076


#8

No it never gave me an error code at all. We finally got her pump on Weds (when they said they’d overnight it and we get it Tues!)

Our nurse told the childrens unit at the hospital where she keeps the loaner so this shouldn’t happen again (I hope not with us at least!)

We have our next appt in Dec, so I will be asking to switch to a different pump if they can’t guarantee us at least a backup minimed on the weekends if this were to happen again.

I’m still disappointed that I couldn’t get any tech support, here or the US one. Can’t get it here on the weekends and then having to rely on calling out of the country and can’t even rely on getting through that way, isn’t a great feeling at all. Although at this point the pump was FUBAR… and replacement was the only option. But it still it would be nice to be able to ask a tech questions in case it was user error on my part or something!