Xdrip problems, unable to upload, bluetooth connection errors

For the past 2-3 weeks I have been receiving error messages on my phone with a pairing request. It prompts me to pair my bluetooth to the DexcomH3 receiver every 1-1.5 minutes. If I don’t answer the alert and press the “pair” prompt, my transmitter/sensor disconnects from Xdrip and I do not get readings. Not great for sleeping which is when I need those alerts. I turned on my old Dexcom receiver 3 days ago and it has no problems detecting the transmitter data…ever. It’s just that the sound isn’t loud enough for me to always hear an alert which is a reason why I stopped using it. I do not know how to fix the problem other than to remove Xdrip and re-install the app…if that will even help the problem Grrr. I don’t think it matters but I have an LG V60 ThinQ that was purchased in October.

Which brings me to my next issue. I have not figured out how to upload my data to Dexcom site. I entered my Dexcom username/password into Xdrip but nothing happens. IDK if I am doing something wrong or if it is somehow related to my bluetooth problem. But, if I uninstall the app, I lose all my data. I have an endo
MD appointment Thursday and can’t go there with less than a week of data for the past 3 months.

The other issue is I am supposed to go to endo educator TOMORROW for my 3 hour pump training. How am I supposed to do that if I can’t get my readings properly from my Dexcom equipment?

I am a tech idiot and can’t figure out how to fix it. No one in my house knows what the problem is. I even went to the bluetooth settings in my phone, unpaired everything and then paired devices again. My car bluetooth, no problem staying connected but Xdrip…still no. I get an error message that it cannot pair with the DexcomH3 or nothing happens at all. Phone tells me the DexcomH3 is an available device but when I try to connect to it, nothing happens.

XDrip had several updates in November\December that addressed the BT signal drop issue. On the home screen look for the hamburger (3 vertical dots) on the upper right corner. Press and a menu appears. In the middle of the menu is check for updated version.

XDrip to my limited knowledge isn’t able to upload directly to the Dexcom servers. There are work arounds using Share but many of us use Nightscout instead. The reporting is as or more robust than Dexcom’s reporting, has no 3 hour delay and can be viewed by anyone with the correct url (unless you password protect it). My Endo and spouse have 24\7 access to my numbers which has been very beneficial for me.

1 Like

Thanks for the info, I just checked for an update. Now I wait to see if it helped.

IDK, in Xdrip under settings, there is a section for Dexcom Share Server Upload.It asks for the Dexcom website log in info as well as the Dexcom receiver serial number. I entered everything but it still doesn’t upload.

You are totally right, there is. However, Dexcom won’t accept the data because the authorization “handshake” is invalid. To access the Dexcom live servers or even the Sandbox you have to apply for access. As a third-party app that competes with Dexcom it’s probably not going to happen anytime soon which is why there’s all kinds of workarounds that other people have implemented.

UGH. And the update thing didn’t fix the bluetooth issue

what XDrip version are you now using?

I have no idea

I deleted Xdrip and gave up on it.

You didn’t mention what phone you are using, or whether you’ve tried any of the set up options. I suspect your problems were with your phone disabling Bluetooth to save power, since that is a common problem, but impossible to know without knowing what phone and options you are using.

Xdrip is public domain software so it requires reading documentation, and trying options until you make it work. I really like all the extra features xdrip provides, so it was worth it for me. I use Tidepool instead of Dexcom share and that works with my endo, but may not work with yours.