64-bit Vista and Meter-cable drivers/software?

Migrating to 64-bit Vista, having some issues trying to install the Freestyle USB cable. Haven’t tried the other meters yet. Anyone else have hardware issues mating meters to 64-bit Vista? Can anyone report any successes?

Did some more poking around. One Touch’s site says their software supports 32-bit Windows but not 64-bit. No info from the Accu-Chek site. Inquired at Wavesense/Agamatrix; currently only 32-bit Windows is supported (64-bit-compatible software in development, no release date set).
Looks like I’m not going to be able to be completely migrated until some manufacturer gets on the ball and the appropriate hardware and software out to us users. (Insert long string of expletives.)

Hi !

Problem is with drivers. I have/had drivers which worked on XP/64, but they stopped working (One Touch) (I think that problems started after I installed certain SP)… Don’t ask me how… I have up on everything and I continued development over on linux platform (I am developer developing diabetes software called GGC).

Maybe you should find 3rd party 64 bit drivers. They might work…After I installed XP x64, I searched for drivers for more than 6 months (big things weren’t problem, but small were)…


Really ticked me off after I installed Vista-64 and One-Touch drivers did not work. Have any of you tried it on Windows 7 RC? I may try it this week end to see if it works, I think I installed the 64-bit version.

He he… I am keeping away from any MS OS that hasn’t been on market for a least 1 year… I am still using Windows XP and it will stay that way for next few years… Vista is not good enough for me… ok it looks nice and hace a bunch of nifty features, but mostly it still has problems… My sister uses it since she got it with new computer, so I am having enough headaches from her computer…


I downloaded a third-party hardware driver for the OneTouch but haven’t installed it yet. Haven’t put up W7 yet, need to finish migrating my must-have stuff to Vista-64 before I can free up enough system to try W7 on any system…

If Freestyle is using a Prolific USB adapter cable… install the cable, then let windows update handle it…
Know its not the ideal but Prolific isnt letting people download the cable driver for vista directly… had to do something similar to get a Lifescan meter to work with Vista

Under 64 for the lifescan. i got it working by installing the lifescan driver, then running windows update and it sees that it is a incompatible Prolfic USB to serial and then offers to update it.

It appears to be vendor-specific, as are most of these. I do have a link for another USB cable that is compatible with the Freestyle monitors, not sure if it will work with 64-bit Vista. The Abbott cable requires the disc that came with the Abbott cable (this is how I found it was incompatible in the first place). I just tried to install the drivers for the Wavesense cable and got a similar result. I’ve not found any third-party Vista-64 drivers for either of those. I just installed a third-party 64-bit driver for the OneTouch (wish I could remember who directed me to it or where I found it!) and the OneTouch software. It has successfully imported the readings on the UltraSmart that is my favorite of the OneTouch meters.

I just wish Abbott and Wavesense would get on the ball to come up with 64-bit drivers for their cables/meters.

It may be vendor specific for the actual data… but usually the cable is a smart cable that has a USB to serial converter chip in it (except in the case of the wavesense which is (im guessing) a pullup resistor on one of the USB pins… (Sony did this with some of their firewire cables and you had to use a Sony cable with their camcorders)…

All of them, with no meter attached, come up searching for the vendor-specific drivers – by vendor name.

Got my most recent laptop two years ago – I work with some supergeeks and they all advised me to reinstall at 32 bit level – that 64 bit Vista wasn’t working with anything – including Microsoft products – am not enough of an expert at this to say anything more than am happy i saved all my data and reinstalled the 32-bit version. Might wait for Windos 7 to come out - same super geek friends are on both alpha and beta testing teams and they tall me I will be pleased with this new operating system.

And if you go through all that and then need to get revised software for Windows 7, you might wish you had waited.

So how many computer technicians does it take to change a lightbulb? None – they change the standard to “dark” and upgrade all their users!

The Abbott people were less than helpful about this when I wrote them; they say they don’t support 64 bit OSes and they have no plans to. Nice of them to tell us this before we order the cable. Anyway it’s possible to make it work

In looking at the INF file, the Abbott USB data cable uses a TI 3410 USB to serial device. I was able to download the 64 bit version of the driver for the 3410 device, and change the VID that was referenced in the INF file to point to the one that Abbott uses. In my case, I edited the lines that say VID_0451 to VID_1A61. Check yours to see if its the same by going to the device manager, select the data cable, and under the details tab select the Hardware IDs.

Anyway, after I did this, the driver install worked fine, and the CoPilot software was able to see the meter and download data from it.

Where did you find the driver?

On the Texas Instrument Website. Its a little weird, they want you to sign up to get an account before you download, but search their site for USB 3410. I attached them here as well, I don’t know if the moderator will let them stay

I had downloaded and installed the same file, but Vista still didn’t recognize the cable. Could not find any separate files – only the installation monolith.

After you run the installer, it will place the driver files in C:\Program Files (x86)\Texas Instruments Inc\TUSB3410 Single Driver Installer\DISK1\Windows\tiinst\TUSB3410\Vista64.

Nothing will work if you don;t change the VID as I mentioned in the previous post. But you needed to find where the driver files are to do that change. Then update the driver files through the device manager, and point to that directory (after you made the edit)

Thanks for the info! Found the file, updated it, and downloaded my meters :smiley: One happy camper!!!

I was so bad. I gave the abbott guy what for when I figured out how to do it :slight_smile:

Scott - all I can say is, man - you totally rock! Yeah - it’s an old expression - but I’m an old guy - and what you’ve done with this thing is awesome!

And TuDiabetes comes through again! Just when I thought I was going to have to do a ton of manual entry and the like, I find the answer here. Thank you, thank you, thank you!