Carelink and Mac

Is anyone else experiencing difficulty with Carelink and accessing it through Mac? I've never had any problems, except occassionally having to update my Java plug in. Today I was trying to upload my pump data, and it says I'm missing my Java plug-in and to please click on missing plug-in on your upload page. However, it is not giving me any missing plug-in options, and it is not showing that I am missing any Java plug-in's on my Mac. Is anyone else having any problems?

I use a PC and still have problems with carelink. They’re using an antiquated program that desperately needs an update. Sorry I don’t have a solution.

Have you tried calling Medtronic's 1-800 number ? It maybe time consuming but hopefully worthwhile ?

No not yet. I had updated using my mac in early June and it worked fine. It's showing my Java is enabled. I guess I will have to do that give Medtronic a call, and yes I agree Carelink is a pretty antiquated program. I know they had posted a while back they had "updated" it to be compatible with Mac...but I kinda question how compatible it REALLY is.