Carelink to be updated at long last

Many of us have been complaining about the antique java-based Carelink tool for some time. So I thought this would be of interest, from my inbox this a.m.:

Dear Valued Medtronic Customer,

We want to give you a preview of improvements coming soon and announce some recent updates to the CareLink™ Personal website.

COMING SOON: An Improved CareLink™ Upload Experience!

We listened to your feedback, and in the next few weeks we will be introducing a new CareLink™ upload tool that doesn’t require Java software! We will be sending you an email with a special link that will include install and upload instructions. Stay tuned to begin using our new, Java-free upload experience!

1 Like

I guess my suggestion to them to go to the playground and find a five year old to help must have worked.


Yes, that might have been it. They’re also touting the fact that they are now compatible with the current version of OSX (10.13). Possibly betting that this whole Internet thing may not be just a flash in the pan after all–who knew?

1 Like

Some of us in other countries have seen this interesting. Still we don’t have access (not unless we change our ip’s to our neighbor country :wink: ) and usb’s are still impossible to get. No link 2.4 meters either… i guess we’ll have to wait for a while.

I got so excited when I read this in my email the other day that completely missed the “COMING SOON” part. Of course, jumping on carelink’s website, was immediately disappointed again.

So still waiting for that special link… :slight_smile:

I got mine just now - go revisit the carelink page :slight_smile:

I also got the new uploader. First time it ran, it failed to upload data. I switched the timeframe to “all data” for the second try, and it appears (not sure yet) to be working. I’ll report back success/failure.

EDIT: SUCCESS. (now, if MM would just give us back the CSV export reports!)

It did not work for me - I will try later and post back

To upload data from the Libre reader - you get an ID and password and plug it in.

I would suggest medtronic kidnap some Abbott Lab programmers

I have an extensive background in PC’s and mainframe communications and OS support and struggle with it

I have no idea how the normal PC user has the slightest chance to make the old way work.

I use a MiniMed 722 pump. I also have a Carelink USB stick. I’ve never uploaded my 722 to Carelink. Is it even possible to do this? My pump has no external port to hook up a hard-wire connection but I know that it can communicate wirelessly since I use it as part of my Loop system.

I read a note included with the Carelink USB stick and it warned not to place in an Apple USB port. Of course, this was after I tried to do just that. Bottom line, I was able to download the uploader program but unable to get it to install. Any ideas?

I’ve always had the ContourNext meter that comes with the pump and pairs with it (actually uses RF not BT, but basically the same thing). The meter has a male USB connector: you plug it in to act as the USB interface, and it pulls the data from the pump. Have to keep the pump close to the meter while it’s running.

But as for being unable to get the new uploader program to install, that seems like a different problem. Are you saying you got the program via a USB thumb drive rather than pulling it off the Carelink site? Sounds like it was a Windows version maybe? If you pull it down from it should auto-detect your OS and give you the correct version.

No, I downloaded the uploader program but it failed to progress when I double clicked on the .dmg file in my download file. I do remember seeing reference to “OSX,” an Apple operating system. The 722 doesn’t have a linked meter that I know of.

It’s not real important to me but I thought since I had the USB stick (I’m thinking this is an antenna only, but not sure) and thought I might investigate what the Med-T pump reports look like.

I’ll check out the 722 User Guide.

Yes, .dmg (for Disk Image) is definitely Mac-speak but obviously you have to get data from the pump to the app.

I’m using my old 723 (which I went back to b/c as a manual pump it’s less aggravating to use than the 11-clicks-just-to-suspend-your-damn-pump 670G), and the uploader seems to work just fine–connected, showed it was uploading etc. Except that there’s no data in any of the reports. Guess I’ll have to contact Mdt.

what OS and browser are u using that u can’t get the new uploader to work? I’ve got Win 7 (64 bit) and downloaded the uploader while on Carelink in Firefox. The upload process shoots us over to the uploader app, which then uploads to MM servers. From there, the FIrefox browser had no issues generating reports.

The Carelink USB stick is not compatible with Mac. You would need to get a Contour Next Link meter. The Contour Next Link meter is compatible with the Paradigm series pumps.

LOL! ah the old Carelink USB hardware. I’ve got all that tucked away somewhere, gathering dust. That hasn’t worked in ages. Myself, I upload using the Next Link meter.

Thanks for the info, everyone! It looks like it’s more trouble than it’s worth.

1 Like

Dave it was probably me. I used chrome -

Tried it again and it went smoothly

Seems pretty decent -

Carelink and Dexcom Clarity BOTH now work on a Mac, as well as PC. My wife is a happy camper again, as she doesn’t like having to do all of her reports on my office PC instead of her MacBook Pro.

Carelink always lags behind OSX updates but you can get around it by manually altering your browser’s User Agent setting to whatever earlier version Carelink wants.

Made me lol. I am 670G study participant for 3 years, Mac user. Have to do do uploads at my office where IT guy set up old explorer version so I can connect! Delighted to learn of update. I had even mentioned problem to pump designers in addition to problem with clip. Mac and Java don’t like each other and adding Java caused significant stress, distress and downright wrath on this 70+ YO!