Carelink doesn't support OS X 10.11 El Capitan yet

Haven’t been over to upload data to Carelink for a while, not since getting a new personal laptop and a new computer at work, both running OS X 10.11 (El Capitan). And lo, once again I’m out beyond the boundaries of what Medtronic supports. Currently the Carelink site doesn’t go beyond 10.10. Last time I hit this it was several OS’s back, Yosemite I think, and it was a year past the release date when Medtronic caught up. I gather from that time around that it’s basically an FDA approval issue. But even so, it’s kind of a reminder how quickly things that once seemed very leading edge start to be creaky and old fashioned in the digital age. And pump technology among the creakier and old-fashionedier. Come on, Medtronic, you can do better than this cantcha?

CareLink should kinda, sorta be OS agnostic since it is a Java app running in a browser. Have you tried browsers other than Apple’s Safari?

Not a browser issue. The error message highlights the OS version number as incompatible. It may be that there’s no substantial technical issue, but they don’t let you into the site if your OSX version comes up 10.11. With Yosemite they told me it was an FDA approval matter and I assume this is the same. And anyway I was using Firefox–I don’t think Carelink has ever worked on Safari.

Do you have a screencap of the error which is posted? Or to put it another way, is it something other than this one which allows you to continue on through to the CareLink Sign In page via the button at the bottom?

I didn’t see the link at the bottom, but that’s the page yeah. Site’s down right now (!) so I can’t test if it will actually let me upload data if I do go on into the site.

Ok, server’s up again. Can’t seem to upload an image here so no screenshot but I get the same page as you, except for the part that says “you may still use CareLink” at the top and the “Continue” button at the bottom. In other words, fakakta. Or as we say back home, S.O.L.

The steps to be able to use Carelink with El Capitan are:

In Safari if you don’t already see the ‘Develop’ menu you need to enable in in preferences as follows:

  1. Launch Safari
  2. Go to the ‘Safari’ menu and choose 'Preferences"
  3. Select the ‘Advanced’ tab
  4. Tick the ‘Show develop menu in menu bar’ at the bottom of the dialogue box.

Now, to use Carelink:

  1. Launch Carelink and when you get the error click on the ‘Develop’ menu and choose ‘User Agent’
  2. Next choose ‘Other’ at the very bottom of the menu
  3. you will now get a dialogue asking you to type a customer user agent for this page
  4. In the dialogue box you will see a user agent string like this one:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/601.4.4 (KHTML, like Gecko) Version/9.0.3 Safari/601.4.4

  1. Edit the string shown by changing the 11 (bold and italic in my example) to a 10 so you should end up with something like this:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/601.4.4 (KHTML, like Gecko) Version/9.0.3 Safari/601.4.4

  1. Click on ‘OK’ and the page should reload and display without the error.

The only issue is you have to re-do the user agent string bit each time you want to go back into Carelink.

Hope that works for anyone who needs it.

1 Like

Interesting–I tweak user-agent settings for web development stuff, but hadn’t thought of it for this. I’ll give it a try!

I am in the same boat with Windows 10, to which I upgraded my laptop. It’s annoying as hell that while Medtronic are trumpeting their partnerships “Samsung” “IBM”, they have left us in the lurch. I’m still too lazy to contemplate leaving but if it’s June and nothing has changed, it might make me consider shopping around.

If it’s not actually a technical incompatibility, just a matter of lag in getting FDA approval for the more recent OS’s, then the user-agent trick should work. Haven’t had a chance to try it yet but I suspect that’s all it is. I assume you can do the same hack with IE. I know you can with Firefox, though you might need to download an extension for it, but that’s no big deal.

I don’t use Win 10 regularly (yet), but a few weeks (?) ago this came up so I booted my Win 10 system & tried it. At least back then I got the warning message with the blue “Continue” button at the bottom of the message. (See screencap below).

If that’s what you are getting, then just press Continue and you should be just fine.

Is there an emoticon for crossing fingers?

No, on OS X 10.11 there’s no “continue” button, just the “Bridge out, no access” sign. Haven’t had a minute to try the user agent dodge yet.

I believe you. However, when I tried it a while ago in Windows 10 the “Continue” button was there. But I really need to try it again to see if this has changed.

No good reason it should change of course … I say as though that might actually matter. :smirk:

Thank you for the work-around!! I was able to FINALLY upload my son’s pump data onto CareLink for the first time in months!

1 Like

Yeah, Medtronic confirmed to me that it was an FDA issue with the OS version change rather than a technical problem - I have bene using it for several months with the work around it it is working just fine. Of course they did not say that the work around would work, just that they are waiting - I have never been good at waiting though.

Thank you NomiSimoN - this is an ingenious hack, and worked for me. I am very grateful for the step-by-step directions.

Funny thing–I was just about to go looking for this post again when your comment made it pop up. I wanted to try out the Tidepool Blip app someone just posted about, and I haven’t uploaded anything to Carelink for months because of this problem. Well, and also because laziness. Anyway, I use FireFox for Carelink just because it has my login in the security prefs. I use an extension called User Agent Switcher. I tried a few different ones that didn’t get me past the block until I tried Chrome 41.1 OS 10_10_1 (Intel). That made Carelink give me the “continue” button after the warnings (finally!) so I was able to click through and upload my pump. Yay.

And anudda thing: the Carelink app uses Java, and in the nature of things that means almost every single time I log in it says I need to update my Java client, because Java is such a security nightmare that they update it like every couple of days. Which is neither here nor there except that some time in the last year or so Java decided to strike a deal such that the update process will switch your default home page and search engine to Yahoo! if you’re not careful. The lame helping the blind, I guess you could call it. Anyway you want to remember to uncheck the box that says "Make Yahoo! my default search engine in the Java updater. Unless that’s what you want (though I question your sanity).

Just a friendly PSA…

I was trying to find a work-around this morning (and still am). The great suggestion from NomiSimonN helped and I got into Carelink, until I got to Java. I downloaded Java but I can’t get around Safari’s security blocks. Even using the Java suggestions doesn’t help. I am frustrated! I’m so close…anyone have any more help?