CoPilot software with new PDM's

I have installed & uninstalled & RE-installed the CoPilot software (and Omnipod PSR Extension) onto my laptop. But it STILL gives me error messages everytime I try to download data from my PDM. Even after trying several USB cables, the download just won't happen.

The Friendly software technician from Omnipod Customer Care walked me through the entire troubleshooting process quite patiently during our 75min telelphone call, but in the end he was unable to explain the persistent "code 2" error messages.

I have no issue using this same Windows Vista HP laptop for my Dexcom software, and Patient Friendly Software Technician assured me that it indeed met the 'minimum system requirements' for CoPilot. He admitted defeat, and suggested I try installation on a different computer. Sadly, Patient Friendly Software Technician is unable to assist me in purchasing said 'different computer'. :-(

So I am coming to the REAL EXPERTS, PWD's who actually use the PDM's and CoPilot software. HELP!!!

I think there is a (subtle) problem with the way the Omnipod software uses USB communication. For instance, running the software on a VM (virtual machine) completely crashes the PDM- everything is wiped out and you have to reprogram all the settings.

You are running Vista, which is I think rare these days. The software is written to run on W XP and W 2000 but others have said it runs fine on W 7. It could be a W Vista problem, or a hardware problem with your HP laptop. Not necessarily a real hardware problem, but something "different" that the software drivers cannot deal with.

I think the whole problem lies with Omnipod. Probably sloppily written code for the Extension, or something wrong with the Copilot software, over which they have no control.

Thanks for the reply & info Mark. I suspect you are correct. Do you think the software is worthy of any further endeavors on my part?

Have you tried to install the software by using "run as Administrator"? Tried to actually run the executable after forcing it to XP Compatibility mode?

Hello Mark,
I was having the same issues (USB not working) on my mac w/VMware. I poked through the web & saw several posts that led me to believe that Parallels actually works in a VM. I have previously owned Parallels so I bought the upgrade for 35 I think, installed it, fired up my Win7 VM and the dexicom & copilot software reads the OmniPod meter properly.

It was very frustrating for me to have to boot in native "bootcamp" just to read my meter & not have ready access, without rebooting my Mac, to he data.

I am even running Mavaricks if anyone cares.
btw: The Omipod software sets up a .Net device (no com port assigned) for the USB & that is the rub.

My next thought is I am wondering if you have installed the Omnipod software so that the USB driver installs? The Omnipod software only reads the meter and gives you a log. Try to get that part working outside of co-pilot. Once the Omnipod software is able to read the data, the co-pilot extension should work.

I know it is seemingly a dumb question, but, there is no such thing as a dumb question. After you install Omnipod & co-pilot, reboot. Right click on the software, pick Properties from the popup menu, and choose to run the program as a Windows XP program.

If all this has already been tried, I apologize for being so long winded.

Interesting- I tried last year a W7 VM with Parallels, VMware, and Virtualbox and they all crashed and wiped out the OmniPod. Also the new Dexcom software stopped working - could not recognize the G4 device.

So with Parallels latest version (v. 9) and I am assuming the new Omnipod system you are not having issues? And also the new Dexcom software is working?

If so, I will try that.

Does anyone know if the software works on Windows 8 - either a real machine, or a VM?

I to have a mac running Maveriks and a VM and I have had no problems, I like it actually since I can make it work within my Mac. but would be nice if the software could work on all platforms including a windows and mac version.

I hope that you find the problem Mark, good luck

I am still on the old PDM not the new one yet. I hope there will not be problems with the new one when it comes to canada

Hey Mark,
I also have a Dexcom. That USB driver will not work on Windows 8. The reason I bit the bullet on the parallels software was that I had read online that it would work. Previously, I had to boot using bootcamp to get the Dexcom working.

Parallels has a free trial. Give it a download, install windows 7 & the dexcom software and you should work fine. The Omnipod driver sets up a virtual com port on the computer so that can be seen in Control Panel -> Device Manager. You will either have an unknown device listed in USB devices or you will see a com port show up in the ports section of the Device Manager.

I did not have the issues with Dexcom. My issue was having all my data in one place. I am also working on a Demcom - co-pilot interface script. It is about a month off as I have several projects ad this is lower on my priority list. I will let y'all know when I have success....

Best of luck!

There's a post in the Dexcom forums here that has a download that will make the Dexcom's work with Windows 8.

The reason for these problems, as well as most problems with medical devices is that they are "old school" in the communications. The USB is actually a USB to Serial interface. Most, like the Omnipod have moved the serial conversion to inside the device, rather than having a funny cable like many had years ago. But this still requires a special driver to be used to translate the internal device's serial information into the modern USB signal.

Bottom line is, this setup simple does not work with every computer. As standardized as USB is, far too many companies don't quite follow the standard and try to make their USB ports "better" (i.e. worse....) HP is notorious for this type of hardware stupidity. Apple is even worse at this. One of the reasons you always see the "will it work with Apple" question. Simply because so many things that follow the proper standard won't work with these machines that do not follow the proper standards. Frustrating to say the least.

SueSue, one thing to try is to contact HP and see if there are updates to your system. A new BIOS sometimes fixes issues like this. Or a new mainboard driver might also help. Not a big possibility, but worth a try. HP though is known for giving up driver support for systems very quickly so updates are rare on most of their equipment.

In europe we use mylife Diabass software. Try it.

there is also software available to download the config of your PDM. Use full as backup for installing a new PDM

Update: Insulet support has continued to work on this issue with me, calling me several times with new things to try. None have worked so far, but they have sent me a new PDM thinking it could actually be my PDM. I activated a new pod today using the new PDM, so I should be able to have ‘sufficient’ data to download by tomorrow pm. I will let you, dear Fellow Podders, know how it goes…