Dexcom G5 iOS App bug causes loss of calibration


#1

I have used CGMS for 12 years now. Started with Medtronic and switched to Dexcom about 5 years ago. I have used the G5 with my iPhone for the last year.

I am using iOS 11.2.5 on an iPhone 7 Plus and my Dexcom app updated automatically last night to 1.7.0.

Unfortunately the calibration screen is rendered useless for me with the latest Dexcom app. The keyboard for entering my glucose level now covers the green save button. There’s no way to minimise the keyboard to get to the green save button and thus I cannot enter a calibration reading! I have rebooted and re-installed the app without success.

I have spoken to the Dexcom tech support and sent the screen shots but they are not any more technically proficient than I am and all they could do in the end was “we will investigate this and make get back to you next week”.

If anyone else noticed this bug, please contact Dexcom to report it. If you haven’t updated to 1.7.0, then hold off or update at your own risk.


#2

@swim489

Dexcom released version 1.7.3 of its G5 Mobile App for iOS on September 18, 2017. This release was specifically for OS compatibility with the Apple iOS 11.

If you are not using the version 1.7.3 of the Dexcom Mobile app and using the iOS 11.x and having troubles, I would suggest you upgrade your mobile app to the latest current version of 1.7.3.

We have been running the Dexcom G5 Mobile App version 1.7.3 on an Apple iPhone with iOS 11.x for a few months now and are not running into any problems.

NOTE: We are running the Apple iOS 11.1.2 and have NOT yet upgraded the phone to 11.2.x.
The Dexcom Compatibility Matrix does not make mention of 11.2 yet so perhaps this could be the issue?

https://www.dexcom.com/faq/what-devices-and-software-are-compatible-dexcom-cgm-apps


#3

Unfortunately, dexcom has only released version 1.7.0 in Canada (and they did this last night!). I have no idea why they have not put 1.7.3 onto the Canadian App Store. 1.7.3 yet.


#4

@swim489
Well that is certainly odd. I would suggest to download the one from here but I assume it would play havoc with the units display.
Perhaps the apps simply do not correlate in terms of the version numbers between the Canadian and US versions.
Can you post what the version history for the Canadian app looks like? Here is the US:


#5

Attached is version history photo of 1.7.0 Dexcom app in Canada.


#6

@swim489
Interesting. Hard to tell exactly but it sorta looks like the Canadian version may be ahead of the US version in terms of the actual updates?
And with the version numbers between Canada and US simply not correlating?

I do hate the generic “Bug fixes and performance enhancements”. Sure is possible to hide a whole lot under that heading. It would be nice to show the actual details.


#7

Can you snap a screen shot and post it? On of the issues I worked thru with Dexcom last fall was a color issue that made calibrations nearly impossible.

I’m using iOS 11.3 beta with the 1.7.3 Dexcom app.


#8

Here is screen shot.


#9

Interesting. It doesn’t look like the keyboard is covering the button (and the Cancel), just that they are not there. Have you tried pushing just above the #2, in the white area, to see if anything happens?


#10

This happened to me as well! I was forced to update my app to the most recent version 1.7.3, but I had been using the 1.7.0 because it enabled me to silence all alarms easily. The 1.7.3 version will give an audio alert if you don’t acknowledge a low or urgent low alert within a certain number of vibrations.

I tried all sorts of ways of getting around the stupid keyboard, but I never managed to get it to work. I had to update my app.

Dexcom will need to create an updated version of the app for Canada if the newest IOS update doesn’t allow functionality of the Dexcom app. Sounds like you’ve already called them, but another phone call asking for this might be a good idea. If you’ve purchased sensors and transmitters with the expectation of using your phone, then they really need to fix the app.


#11

I can “see” the green save and cancel buttons on the calibration screen for a brief second before the keyboard appears on top of the buttons to enter a value.

It’s too bad the app doesn’t use the iOS keyboard which would allow an enter action or a move the keyboard out of the way action.


#12

At first glance, it appears likely the Canadian version 1.6.1 was released for the iOS 11 compatibility.


#13

By iOS 11 compatibility, do you mean just 11? or do you mean for 11+?

This happened for me with the 11.1.2 update. I’ve been more cautious in updating my phone since then. I had the exact same issue as described by @swim489 where the keyboard would not retract.


#14

I suggest logging into the US App Store and updating to the US version. But it requires a second Apple ID.


#15

If you have the “Larger Text” Accessibility setting turned on, try turning it off. Did you try changing your text size to a smaller one?


#16

Thanks for more ideas -

I don’t think it’s a good idea to try and use the US version from Canada. I know the US dexcom servers where data is stored is different from the rest of the world’s dexcom users due to different privacy laws and I’m not sure if changing App versions would mess that up.

I do not have large type set on in accessibility.

I am able to occasionally get acces to the save button by restarting the app several times and changing keyboards in the iOS settings (ie disable the emoji keyboard while trying to enter data even though the app keyboard doesn’t have access to the emoji keyboard). Terribly frustrating. Hopefully they will fix this bug.


#17

Just as a work-around, have you tried xDrip? There has been an IOS version for a while. Downside is that you can’t use it concurrently with the official Dexcom app, but since that’s not working for you… And it has other advantages as well, notably that it lets you see your actual transmitter battery level and lets you keep running it until it’s actually too low to function, as opposed to the built-in cut off at three months. Can add many weeks to your transmitter life.


#18

Having same issue I am in Vancouver BC. spoke to Dexcom USA and Canada, they asked me to reinstall the app, which i have dome now numerous times. A real pain as it takes recalibration of the transmitter and a dozen or so screens then waiting 30 minute. great when its 3am and i am low:-) Anyway, looked for Xdrip but not on my Candian App store, but Sugarmate turned up instead, when i installed it the keyboard issue (hiding the save button) went away. Hooefully the issue stays away now! FYI: IOS 11.2.5 and Dexcom 1.7.0.


#19

Just checked issue has returned :frowning:


#20

Iain - I have again spoken to Dexcom but they have no solution yet. I have found that disabling keyboards in iOS can help as a workaround. For example, disabling the emoji keyboard or Gboard keyboard can sometimes allow the return of the save button.