Here is a fix to run Dexcom Studio with Windows 8

i have created a small tool that will allow you to use Dexcom Studio on Windows 8 to sync with the G4 receiver.

Please be aware that this tool is not supported by Dexcom - i was just frustrated with the lack of official support for Windows 8 and tried to make it work somehow. On another thread this tool was tested by several people - and improved in multiple iterations thanks to their real world feedback.

So if you want to give it a shot despite the lack of official support from Dexcom, just follow the installation steps below. Feel free to contact me if you run into any issues.

The tool is located here:

1) Download and unzip to your machine
2) Connect your G4 receiver.
3) Start InstallDexcomWorkaround.exe (for example just with a double-click)
4) The program will ask you for permission to run as an Administrator
5) The tool will report the status and the apply a workaround to the regsitry so that Dexcom Studio recognizes your receiver.

You don't have to re-run this tool each time you want to start Dexcom Studio - only if you attach your receiver to a different USB-port.

Best regards,

I would like others to reply if they, having tried this, find that it works. If it does it will be a great service to the community. Thank you!

Hi Dondi,

Yes, this works!
Three other tudiabetes users have had it successfully work for them, you can read all the details (and the back and forths with Fabian as he was troubleshooting our issues) in my thread:

I asked Fabian to start this new thread so that his amazing solution would not be buried in another thread!

I installed and was able to upload my results... You are a freaking genius. Thanks!

This is great! Thanks so much for the fix. I will let you know as I use it more over the coming months if i see any issues, but so far no problems.

Thanks for all the responses, Fabian you are really helping us all THANKS AGAIN!

Hi Fabian - would this work with Win7 running on a iMac using Fusion. As it cannot allocate a USB post to the Dexcom ? just wondering if your tool might also fix this issue ?

Hi Fabian - got round to trying it, but seems it needs a Virtual USB port for G4 and VMWare with Win7 does not appear to support Virtual USB so I'm still knackered having to use a PC to download and transfer to Mac.

I can't believe Dexcom hasn't released a fix for this yet. You are awesome. Super quick and easy - works perfectly. Thank you so much.

this is great just found this site and it accually worked on my pc with win 8 thank you so much so will this work on apple computers also i will have to try it on my mini mac and see thank you again fabian that is great

What a fantastic and simple fix! Very helpful!

Dexcom should hire you, Fabian!

Now, however, my home network is Mac and the printer routes through AirPort Extreme. I’m using Bonjour to convince my Win 8 laptop to print but cannot print .doc reports.

Haven’t yet tried connecting laptop directly to printer via USB but will do so shortly.

Wish reports could be saved as a PDF file, like I do with Omnipod and sent in that format to my endo. Doubt her office can use XML or tab delimited.

Maybe someone knows a way to get from XML to PDF?

I just followed this posts instructions and it worked! The only problem i'm having, and I don't know if it's related to this fix or not, is now my computer says it can't open .doc files?

When I click 'View Report" or "Print Report" in Dexcom Studio a little window comes up and says:

"This computer is not configured to accept the 'Open' command for '.doc' files."

Did anyone else have this problem??

Yeah, that is an error that I used to have on my Windows 7 machine, so Dexcom Tech support told me "the temporary fix" for it.

You have to go to the /Temp directory and the files show up in there if you click the Print button.
For example, mine are in:
C:\Dexcom\Dexcom Studio\Temp

It's a bit of a pain, but I just make a shortcut to that folder and every time I print/save a file, I just move it out of that Temp folder and rename it.

What is odd is that this error didn't show up for me in Windows 8 until a couple of months after Fabian's awesome fix!

Thanks so much.. I did this several months ago with great results. The only issue I am having now is although I can download my G4, I cannot print from the studio software. Am I the only one experiencing this? Thanks in advance. Carolyn

Do you get this error:

"This computer is not configured to accept the 'Open' command for '.doc' files."

If so, read my reply just above yours! :-)

No, I get "unhanded exception: no application is associated with the specified file for this operation."

I did try your fix though, and it worked. Thanks so much.

Great workaround! Just installed it, works great with my Dexcom G4 on a Windows 8.1 box. Bravo!

OK, I have a worse problem. I have a Mac, and used to use Diasend, until they caught on to the fact that we were using it illegally. So my brother gave me a Windows XP. Is there any way to use Dexcom Studio with a dinosaur?