Software for new Omnipod (PDM model UST-400) on a VM running Windows XP? Crash the PDM still?

I use a Mac and run a VM (as little as possible) with Windows XP on Virtualbox or Parallels. When I ran the Copilot software in those environments with the UST-200 (previous generation) the PDM would crash and ALL the settings were wiped out. Using Bootcamp to run native XP worked fine. Must be an obscure USB software/hardware bug.

Has anyone used a Windows XP VM on a PC (not a Mac) and seen crashing of the PDM?

Has anyone tried the Copilot software with the new Omnipod system to see if VMs work OK?

It is pretty abysmal that Insulet still requires the use of ancient crapware like windows XP and windows 2000. I bet the number of actual customers with access to that is less than 10%.

Not sure about your question....kind of have a question of my own. Did anyone else experience HUGE battery drain when plugging the UST-200 into the computer?

I haven't tried my UST 400 yet...just curious

Your question is a little confusing to me. Is your PC running Win 7 or Win 8 and so you're wondering about running XP in a virtual environment on a Windows machine?

All I know is that the old PDM (UST-200) and co-pilot software work perfectly fine on my Windows 7 machine. As far as I am aware there's no need to run XP just to use the software. I'm not at all sure about compatibility with Windows 8, but at least from my anecdotal evidence there's no problem with the PDM working in Windows 7.

Edit: Also, not to be difficult, and not that I don't agree that it would be ridiculous to only support Windows XP, recent statistics show that XP makes up 37% of desktop operating systems in use.

I never really noticed that. Sounds weird! Like, the battery level drops once you remove it from the computer? I suppose I could see it being an inefficient USB port or something on the PDM end where the resources required to transfer information are really taxing on the system. Who knows.

I have a Mac running OSX. Whenever I need to run Windows or Linux, I use a VM running also in OSX. Except I cannot use the Copilot software in a VM because it crashes the PDM. All other Windows based software that communicates via USB to other hardware seems to run fine in a VM. I can use the Copilot software by rebooting my Mac to run native Windows.

I think most of the XP is pirated copies running outside the US...

First, use Windows 7 in bootcamp only. It wasn't a bug, but just 12 year old technology to blame. Macs have never had that good of USB support, so Parallels will always have trouble in that attempt.

Mine does on the UST-400. Don't know the cause, but it is weird. :(

I've never been able to get mine to work through VMWare. :(

First, I am "a bit slow" on computer, what do you mean by "run a VM"? I have a MacBook Pro with Core i5 processor. I could not get the software to download when I first received the UST400 (the first time I tried it looked encrypted and gave me a message that it doesn't work with Macs). I have never tried to download anything from my PDM via USB port because I didn't think I had the program to utilize the information.

I also have a mac hubby still likes windwos so we loaded the software onto that, not showing up any of the BG I put in, now wondering I am only playing with it, I do not have a pod on since my training date is in 2 weeks. but I put in my blood sugars three times and shows up 0 readings. I have tried in VM and on a windows machine, nothing for both, does not seem to want to download the data shows 0 in the data report. shows ready however but then no readings, could this be since there is no pod? can’t see why it would not download my sugars. sigh if anyone knows if it is the software that is buggy please let me know how to fix this. Frustrated as hell.
darn windows. just got the insulinx meter a while ago got that working on the mac now new issues with this, how am I to show my data if I can’t even download it?

I am in Canada also and a lot of the info is for a us meter.
hoping someone can help.


I read in the omnipod extension guide on the internet that the Omnipod will not download anything until it has a 24h period in data. So Tomorrow I will check to see if that was what was wrong here with mine. I hope so. $5 grand is a bit much if the software does not work. Wonder what ppl are doing that only have a Mac.

VM means virtual machine. Basically you run a program on your Mac that contains an instance of Windows inside the program. So you're running both operating systems simultaneously. What Mark is saying is that when he tries to do this and use the Co-Pilot software, it crashes his PDM. No good.

Scott above suggested running Windows 7 in boot camp. Boot camp actually installs Windows to a separate partition on your hard drive so you can boot either into Windows or into OSX, running the full version of whichever one you choose with no limitations. It's pretty great and convenient, and all you need is a valid license of Windows. This link might help:

And if you only have Macs and no access to a PC, it might be worth checking out if using Co-Pilot is important to you.

I am with you. I run VM's on my Mac all the time. Major PDM crashes. I tried twice and learned. I have not tried Co-Pilot on any VM inside an XP or Windows 7 machine but I too am curious. I would hope someday Insulet would lobby to have Co-pilot developed for the Mac as well.

I have a MacBook Air (mid 2011) running OS X 10.8.4 and run Parallels 7 from an external HDD with Win7 VM. I run Co-Pilot on there just fine... I told the port selector wizard in Parallels when you plug in a new device to only use the PDM with Windows. Works just fine. It has never crashed my PDM or erased setting or data.

Is this success with the newest Omnipod with PDM UST-400? I have tried all possible VM software with Windows XP and Windows 7 an always get a fatal crash with PDM UST-200, wiping out everything.