What am I missing/Am I an idiot?

Got my Dexcom today and figured the first thing I should do was charge it. Plugged it in and heard a beep then nothing, no charging bars nothing. Unplugged it and tried again, not even a beep this time. I am tech savey but I cant even charge my receiver! Gonna call Dexcom tomorrow but has anyone else experienced this? It’s driving me crazy(on top of my insurance messing things up)! I cant sleep because I cant charge a receiver!

Call Dexcom… most likely your receiver needs to be replaced. I had one “die” this way… I wasn’t wearing it for a few weeks and it wouldn’t turn on when I went to charge it and use it again… it beeped once and the lights on the button pad would light up, but nothing other than that.

I think I had the same thing when I got mine. If I remember, a pin was bent on the plug connector to the dexcom. They sent me a new plug and I haven’t had an issue since…good luck… I should say I haven’t had THAT issue since :slight_smile:

Just a longshot, but there is a reset button on the back that you can engage with a paperclip or toothpick…the reset is a very small hole on the lower right or upper left side on the back (depending on the direction you are holding it). I also assume you are charging it in a wall outlet and not the USB connection (dumb question but just want to rule that out).

Also: on the very FIRST charge-up, it might need quite a while before it has adequate voltage to show anything at all on the screen. I assume that it’s so late by now, you’ve already given it plenty of time and “ruled out” that possibility. 3 hours. And make sure that wall socket really is “on”; there’s a chance that you used a live socket the first time, but plugged the charger into a light switch-controlled socket on the same faceplate (one which has no voltage, because the wall switch is turned “off”). All of the other replies are really good, try everything.

I agree with Todd: Take a good look at the contact pins in the Receiver’s connection shell. If they’re not in a nice, even line, you can try shoving the misplaced place ones back where they belong. The charger’s connector is less likely to have bent pins, because they’re set into plastic channels - but take a look there, too. And as Kevin said, start with the reset switch. But please, PLEASE use a paperclip, and not a toothpick!

Kevin: How could someone mash a USB connector into a Dexcom? The two kinds of shields are incompatible, both length and width.


Since both the data download cable and AC adapter connect to the dex at the same point, I think what Kevin meant was to remind Seth that unlike many of our electronic devices (Blackberry, iPod, etc) the Dex doesn’t charge when connected to the USB cable and a computer; it only charges with the AC adapter.

Kevin: If that isn’t what you meant, my bad.

Reset button worked!!! I had looked for some form of reset when it wasn’t working and the only thing I saw was the white square notch on the end and that didn’t do anything. Really wish the reset would have been mentioned in the trouble shooting guide.

Thanks for the help.

Yes, that is what I meant.