Animas fixes its ezManager Max software

For those of you who don’t know, Animas has finally updated its ezManager Max software. It is now, in fact, compatible with the Mac OS 10.5 system. For more information, check out my blog posting about it at, or contact Animas at 1-866-949-1529.

well, the latest OS is Snow Leopard 10.6 and it doesnt work with that very well. I never had a problem getting the software installed, it just freezes up every time I would try to use it. Until they come out with 10.6 functionality, Im just gonna boot into XP and do it that way

To be clear, do you mean 10.5 (Leopard; released Oct. 2007) or the latest OS, 10.6 (Snow Leopard; released Aug. 2009)?

As I understand it, the software has always supposed to be compatible with OS 10.5 (whether it works well or not is another issue), but has never been compatible with 10.6 Snow Leopard. So, which OS are you using? (Look under your Apple menu to find out. It’s in the upper-left-hand corner of the screen and select “About this Mac”).

I ask because I just paid $150 to update my old computer to 10.5 (from 10.4), because my new computer uses 10.6, and therefore won’t won’t with ezManager. So, if the software is now compatible with 10.6, I just wasted $150.

I’ve only run it with 10.5 and aside from being sent the wrong version initially (which Animas took care of), I’ve not had any trouble running it in Leopard…

What do you mean “the wrong version”? I thought the CD contained installers for both Mac and PC. What version of ezManager Max do you have? Mine’s 3.0.6.

I have 3.0.6… which is what the “wrong” version said as well, but it had a different version @ printed on the disk itself (might have been 3.1.14?) and the disk itself was a burned and inkjet printed disk, not the same as the professionally pressed and screen printed one they replaced it with. It would see my pump, but not download anything - it would just tell me “No pump found matching the selected model” despite the fact that it was showing up along with the serial #. Like I said, it was weird… they had a back-order on the software for a while last year, so I suspect that someone was trying to “help out” and burned the wrong copy and included it with the software kits.

Interestingly, I returned that original “wrong” disk as requested (they sent me an RMA label) and every few months I get a request from Animas to return it again because for whatever reason they had shipped me two replacements… it’s kind of annoying.

Im kinda confused about this post as well. It was always designed to run on 10.5. I recently received a new disc due to some software issue they identified. I can look at the disc when I get home and see what the current version is.


I have 2 copies of the software, because I was getting a lot of error messages while installing it the first time. The program wouldn’t open, so I deleted and reinstalled it. Still didn’t work. I deleted and reinstalled AGAIN, and all of a sudden it worked (well, the program opens. I haven’t tried connecting the pump yet).

In the meantime, I called Animas and asked for replacement software, which they sent immediately. The replacement software, which I have not used, has an inkjet printed label, like you say yours does.

I know it’s been said before, but with all the problems associated with this software, it’s pretty funny it’s called "ez"Manager.

I agree… I wasn’t very convinced it was “EZ” at first. Downloading isn’t “EZ” either… with making sure the pump and IR thingie are talking to each other it’s kind of a PITA. To be honest I don’t use the software much…

Animas sent me software about two weeks ago other than some difficulties with trying to sync with the pump(intermittent) I don’t have any issues running the software on 10.6.3

Ok, well, here is the issue I had: My operating system is Leopard not Snow Leopard, and yes the ezManager Max was supposed to be compatible with that operating system, but every time I tried to download the software onto my computer AND my husband’s mac (both of which are on Leopard) it wouldn’t download. So the first time I called Animas they sent me a replacement disk, and I had the same problem, so I contacted them again and they sent me another replacement disk and same problem, both computers. So I sent them another email, and a tech person called me and did in fact confirm that there was a problem with the software (he told me that he only found this out after scrambling to find a mac in their office with Leopard on it). He said that they were working on a work around and that could take awhile. So I waited a couple of months, and started to get a little annoyed, given that Animas was billed as being both PC and Mac friendly. And i know that some of you say that it did work on your computers, but if it somehow works on one, but doesn’t work on others (it wasn’t just one computer this happening to) then yes there is a problem with it.

So, when I got the upgraded version of the software, this is an excerpt from the letter they sent to me:

ATTENTION: Apple Mac OS computer users
Information on ezManager Max Diabetes Management Software

Dear Healthcare Professional, –> as I mentioned in my blog, apparently I’ve moved up in the world!

We are contacting you to make you aware that the ezManager Max software you previously received will not function with an Apple computer. When the CD is placed into the Apple computer, the software will not load. –>exactly what was happening to me

The compatibility issue has now been resolved to meet system requirements as specified* . Enclosed in this package is a new CD that will install ezManager Max software onto an Apple Mac OS 10.5 computer. The new CD can be identified by a yellow dot. Also enclosed is the most current version of the ezManager Max User Guide.

So there you go. While it may have worked for some of your computers, it didn’t work for mine, and by the sound of it, it didn’t work for a lot of others. And the upgrade seems to work great for downloading my blood sugars off the glucometre. I haven’t yet figured out how to download the information off of my pump, but that may be a Mac issue from what I’m reading on other forums. If anyone has any information on how to download off the pump, that would be awesome.

Thanks so much. And hopefully this has helped some of you.

thats where I have had issues its not 100% all the time with pump also I found when I initially installed the driver, it likes the same USB port … doesn’t seem to scan all ports correctly.

Hi everyone:

I´m from Spain.
I have animas 2020 and a Mac.
I can´t use the software because here is not avaiable the mac version.
I have sent an e-mail to animas, they pass me to local distribuitor and said: we´re sorry, we don´t have mac version, use windows version

I have paid 3400€ for the pump, 200€ every month and they don´t give me a CD, I´m very ungry
can someone pass me the software?