Animas Ping Meter Remote Problems

I’ve been having some problems with my (brand new) Ping’s meter remote. I just got this meter remote along with my brand new Animas Ping about three weeks ago. Just wondering if any other Ping-users are having similar issues?

  1. My meter will give me wildly erratic readings. For example, I will test, it says 57. I don’t feel low at all and my Dexcom says 250. I test again, and the meter now says 246. I expect semi-inaccurate results, but this is well outside of that +/- 20%, right? It doesn’t do it all the time, and I have had pretty accurate results in between these occasional crazy results.

  2. I will do a test, then go to bolus using my meter and the meter will say “you have not tested in the last 15 minutes” even though I just tested 2 seconds ago. This actually happens a lot. Like once a day, or once every other day. Am I doing something wrong here?

I called the company, and went through all the normal shenanigans with them where they try to determine whether it’s actually your fault & not the meter, but they decided to send me a new meter anyway. Which, is probably a good thing. :slight_smile:

Anybody else experience anything similar, or did I just get a wonky meter?

we had the same kinds of problems with the one touch ultra. it did not record BS tests even though my son swore that he had tested. the meter got replaced free of charge, but it happened with different meters, but… it happened only to my younger son, not my oldest who used the same brand of meter. My youngest son decided that maybe it was because he was pulling out the test strip too fast after the reading and slowed down and he has not had that problem again. Of course, we are not sure, but moving a bit slower when testing does not hurt.

Maybe one day they’ll create technology that can keep up us. :slight_smile:

I actually think it would be better for people to slow down than technology to speed (us) up, but that’s just me!

Anyway, sorry you’ve had these problems. I got my Ping 3 months ago and it’s worked fine and seems to be as accurate as my Acuchek which I thought was pretty right on. The only issue I have with the meter remote is that damn speed scrolling …see I told you it needs to slow down…lol

Ha! That is true, the speed scrolling is WAY too fast! I agree with you 100% there! Hopefully the new meter they’re sending me will fix the problems.

I had the exact same problem with the 1st part you mentioned - the erratic readings. My Dex put me at 200, and per usual before correcting, I double-checked with my Ping meter, which put me at 92. Then 260, 240, 102, 202. Finally, I tried my back-up meter a few times and felt the results were consitent enough to go on. The same thing happened again a few days later (with a new bottle of test strips), so I called the company and went through the same rigamarole, and they sent me a replacement meter right away. Ever since then, things have been fine.

I’ve had the same pump/meter for almost 2 years now without (to my knowledge) any issues until now, but then again I just recently got my Dexcom, so I’m starting to wonder if the Ping meter has been as accurate as I thought during that time, or if I was only now aware of it because of the Dex.

Guess there are both pros AND cons of being a cyborg! :slight_smile:

Make sure that your test strips are ALL THE WAY in before you test. I notice that the meter powers on and prompts you for blood even if the strip isn’t all the way in, and then weird results occur.

Weird results can also come from all kinds of things that might be on your hands. We aren’t always by a sink, but it doesn’t hurt to wash your hands first if you are!

I once had the meter tell me I hadn’t tested, even though I just had. I hit the back button to go back to the main menu, then went back into the bolus screen and it worked. I guess it needed time to think about it? Ha.