Dexcom G6 iPhone app issues

I am experiencing repeated issues with my app. I will get a signal that the app has failed and needs to be deleted and reinstalled. When it happened a week ago, I contacted tech support to help me with my transmitter number (required when setting up the new app) and things worked for about a week. Yesterday (June 29) I went through the process several times, and the app failed before ever even connecting to my transmitter. I finally just deleted the app and haven’t tried to reinstall again. Luckily, I am still getting readings on my Omnipod 5 controller. Tech support says this is a known, widespread issue and they are trying to debug the app. I’m surprised they haven’t issued some kind of notice to patients about it.


What kind of phone? I assume it is Apple, because the Android app never works for me, so I use workarounds, but the workarounds are better than the app provided by Dexcom.

iPhone 14 Pro


Mine is mostly working fine. A few issues here and there tho. I think I had one yesterday even. Same phone.

Yup, my Pixel Watch 2 uses Android Wear OS 4.0 on my Android Google Pixel 7 Pro phone. I was using it originally with Dexcom G6 and for the past several months with the G7. For my watch face I use the Blose watch face which is pretty awesome and shows current BG, trend and can drill down to a lot of raw data, graphs, averages, etc. More information than you would normally use, but when you want it, drill down and it is there.

On my Samsung/Android, I need to use a variety of apps to see my numbers as complications*. I use a variety of watch faces, but almost always the information kind, lately the Pixel Fanboy. It can be a bit more colorful and has more complications than most others:

My configuration:


    • a mixture of Complications Suite, Wear Installer, Wearable Widgets, G-Watch BG Provider, although at this point not sure how I get it to work.

Me too - was told to disable automatic iPhone updates and happened again so I disabled update downloads. Happens when I turn phone off and on. Has been 2 hours and hasn’t failed. Earlier today it just kept happening. Hopefully they fix the problem in the update.

Yep, my sis in law just started her first Dexcom G6 and after about 4 days got a message ap failure. Delete ap and reinstall and she did. She didn’t think to call tech support, she just followed what it said. Transmitter won’t communicate with the sensor now. She’s disgusted because she had used a Libre with hardly any issues before the Dexcom.

1 Like

Tell her this is very unusual. I can’t remember a problem like this ever. I’ve been using Dexcom for about 10 years.

I’ve had to delete and reinstall about 3 times in the last three weeks. Good to hear it’s a known issue, so my hope is they’ll push out a fix with the next update

1 Like

@Jim2 I told her I’ve never had that issue. I am a G6 user. But she’s coming from a Libre and it being her first Dexcom. That doesn’t help!

G6 app has stopped working for me three times today now!

1 Like

They have not fixed the issue yet. My sis just called and they told her they were working on it.

The best solve they told her for now is to delete the ap, power off the phone, redownload it and supposedly the sensor and transmitter will work still. That is an unknown factor because she had pulled off the sensor so they are sending her a new one, but that if it happens again she can leave on the sensor.

1 Like

I have had this happen 3 times in the last 5 days. I was able to reset and continue using my current transmitter and sensor but you need the serial numbers. My Omnipod 5 keeps working. Very frustrating. This is something I’ve never experienced before.

I changed sensors Tuesday and re-downloaded the app, which I had deleted. It must have expired because I was no longer getting readings on my Omnipod app. It’s been working fine since. Fingers crossed.

Jim. Welcome to my world. I’ve had this happen twice. Always in the middle of the night. My SugarPixel display goes into alarm because of no data. I to had to delete the App download it again and sign in. Each time there was no great loss of data.
I had a one on one talk with Dexcom’s Tech support.
They said they checked my account, but could find nothing. HOWEVER. When I Frist got the SugarPixel I had issue of it lousing WiFi. Though the help of Apple , found out it was my VPN that was the proplem. The VPN constantly resets the WiFi so often that you don’t it.
I deleted the VPN. But when this App resetting came up. I noticed somehow the VPN. Had reinstalled itself.
This time I removed the VPN App. And have no other issues.

1 Like

I’d been having these issues on and off for awhile but now has been staying on for a few days with the auto updates turned off. Trouble now is that I have no trend graph on the Dex home screen. Just blank white below the current bold, circled BGL. Any thoughts?

**replying to Marie20 and Jim2 Well it’s happed again . Got woke up by my phone with a message “The Dexcom G6 App has failed”. “ DELETE AND DOWN LOAD APP.” Fortunately years ago l’be started keeping the Bo’s the Tx came in. On Reinstalling the App your sent thru the original sign in you went thru when you first installed and need the Tx number and sensor.number.
I’ve texted Dexcom and they gave me a call two days later. Explained all to them and they said they were looking into it.
This left me to believe that they have a bug that has cropped up in the APP.

1 Like