Dexcom mobile App on the Samsung Note 8?

Well, finally upgraded my old S6 phone to the Note 8.
But, after messing with it, realized that it will not install or run the Dexcom mobile app.

I sent an email to my dexcom rep, but no word back yet.

Anyone else have an ETA on it hitting the Note 8?
I know they already have it on the S8 and S8+.
I didn’t think it was all that different for it not to work.

is the issue the version of Android?

The official Dexcom App is only available on devices as specifically listed.

1 Like

Yes, the Note8 runs on 7.1 and the Dexcom only supports 7.0 (on the S8 family.)
I had thought the Note would ship with the 7.0 and work, but it got the update, and now doesn’t.
I know the S8 phones were supposed to get the update somewhat soon, which would mean that Dexcom would need to work on that as well.

Well, seeing as the X2 won’t talk with the receiver, I have to keep my S6 running to get my updates to Clarity for now.

1 Like

This all makes sense, but to your original point, I’m not sure why Dexcom has to approve the app for every single device or version of Android even. The “unlocked” version of the app works on any device pretty flawlessly. 90% of the work is done via Bluetooth, so it seems odd that Dexcom can’t quickly load the app and test it so that we can use it.

I agree, but until then, I installed xdrip+ to use on the phone and see on my gear watch.

My rep said a few weeks…6 weeks ago…

My rep told me to contact support. Their email back said ‘not yet, but feel free to ask again in a few weeks.’ That was a couple months ago.
Meanwhile, updates to xdrip had stopped it from working on the phone.

@Hammer You might try the modified Dexcom app mentioned here:

https://forum.fudiabetes.org/t/dexcom-app-for-all-android-phones/1772

I haven’t tried it on my new Note 8, but it installed on my old Note 4. It didn’t work though because of the BLE implementation on the Note 4.

I won’t install it on my Note 8 because I’m perfectly happy with xDrip+.

I tried that before without success.
I did it again last week and got it running.
I also figured out and got xdrip+ running at the same time as the unlocked dexcom version.
Seems like Dexcom take precedence and was getting pretty solid readings, where the xdrip was missing a few readings.
I uninstalled the dexcom and the xdrip picked up a lot more readings, but it still doesn’t backfill, which is a dissapointment.
My sensor shutoff for dexcom, and my replacements haven’t arrived yet. So I am running only the Xdrip+ for now.

Btw, if you are installing this unlocked dexcom app, make sure to delete any bluetooth settings that has previously paired G5 transmitters. It has to find it again for it to work.