T:slim X2 mystery alerts

I have been getting " Incomplete Bolus Alert" warnings for about a year on my t:slim X2 . About a month ago Tandem replaced the original with a rebuilt but that did not end the problem. The alerts can appear at any time (am or pm) or hours after having any interaction with the pump . Some times numbers appear in the calculations but most of the time zeros are there. There have been 10 alerts today. I can’t see any connection but the screen timeout control has not worked for either of these pumps. At first Tandem suggested it was some kind of user error but two pumps and the same problem makes me wonder if … Has any one had the same issue with the tslim ? Peter 18[date=2021-04-24 timezone=“America/Chicago”]

As best I can remember, I have never gotten this alert except in the context of either having thought I started a bolus or thought I had canceled a bolus. In either case I was messing around with the bolus side of the pump in some way so, even though I didn’t expect this alert, I wasn’t surprised when I got it. :man_shrugging:

I used to get them occasionally. I called them “boob alerts” because they inevitably came from accentually hitting buttons as I tucked the pump back inside my shirt. I almost never see them now that I’ve learned to turn the screen off before putting it away, though.

What do you mean the screen timeout doesn’t work? That sounds concerning! Does the screen actually not go black after the 15, 30, or however many you chose, seconds elapse? I’ve never heard of that and would be stunned if it was malfunctioning in that way and Tandem didn’t jump to fix it. Did tech support test that with you, and actually have you count how long it took for the screen to turn off?

If the screen honestly never turns off, that’s a major concern. Make Tandem replace it now. If it does turn off, then I hate to say it, but it is user related. (Can’t really call it user error.) You’ve just got to learn a new habit.

Have you tried actually pressing the silver button when you’re done using the pump, to put it to sleep where no buttons can be pressed? That’s easiest solution. I find a short screen timeout annoying, since it turns off on me constantly when I’m adjusting settings, so it’s easiest for me to just get in the habit of pressing the button instead.

Have you tried turning the pump so the screen faces the other way?

Somehow you screen is getting turned on and the pump unlocked… Or you just didn’t notice the first round of alerts, and the buttons actually got pushed before you put it away. The whole point of the 1, 2, 3 is too prevent accidental screen unlocking. But if that isn’t working for you, you can always enable the security pin under “device settings”. That will put a key pad up, and you have to unlock the pump with your PIN before you can access anything. A bit more of a pain in the butt, though. I had to do that a few years ago when I was post-op. The percocet they gave me made me loopy and I was actually unlocking the pump myself in my fitful sleep. The PIN made it so I couldn’t get in without being coherent.

I started doing this too, for same reasons you mentioned.
Didn’t take long to make it an automatic habit.

Yes this happens when I hit buttons mistakenly. Also if you enter the bolus screen while you are tooling around. If you enter that screen it’s going to expect a bolus. And even if you clear through it will come back.

2 ways to make it go away.
1 stop insulin then start again. Or
2 deliver 0.1 units.
0.1 units doesn’t much effect me.

@Peter18 , The answer is in the big USER GUIDE from Tandem. Here is the screen shot.