Dex Clarity does not connect - anyone else?

19 July 2016

So, when I plug in my Dex G5 receiver into my Mac laptop the process fails with this message.

There is no user with ID login-session.

It worked well yesterday. Anyone else have this problem? Is it just me?

I’ve just tried and got exactly the same error message after plugging in my Dex G4 share receiver into my Mac. Then I did the same on a PC and everything worked just fine. Tried to reboot the Mac, re-install Dex uploader - no success - same error. Strange. Looks like something is wrong between the Mac version of the uploader and the Dex clarity server. Dex share seems to be running fine. [A side question: isn’t G5 uploading to Clarity automatically through its iPhone app? If so, why would you need to use the uploader for G5 at all? (I’am still using G4, so I do not know how Clarity is supposed to work with G5)]

A call to Tech support might be in order. If anyone gets this sorted out, please post here.

I’ve learned more about this situation. I still get the error message when I plug in the Dex G5 receiver to my Mac laptop. However, when I load up the website, I see that the failed attempt to display the report from my hardwire upload, did, in fact, upload the data to the site.

I had a situation where my receiver had an unbroken stream of data overnight but my iPhone had several extended periods of data dropout. When I tried to upload my receiver with a hardwire connection, it still failed to report, but it did load up the data. When I went to, the data was there.

I called Dexcom twice about this. The rep said he would have someone from the “development team” call me about this. I’m not holding my breath but I’m happy that I’m left with a reasonable work-around.

As an aside, I learned that data uploaded to the server via the iPhone is only updated with a four-hour lag. That;s why I like to plug in my receiver. I get an up to the minute report.

That matches my experience–same error message, but the data were actually there when I logged into the site. I was wondering whether the error was due to the fact that I’ve had my receiver replaced since the last time I launched the app by plugging it into my USB slot–like it didn’t match serial numbers. The site doesn’t give you any options for checking into something like that Dunno. I also sent them a support query email. It has been several days but no reply as yet.

I’ve connected twice with their customer service reps recently who support Clarity without more than a 2-3 minutes on hold.

I was getting this issue also, also on a Mac. I called in and got help quickly.

I’m probably using the same “workaround”: Plug dexcom into your Mac, get the error message. Then manually go to Clarity.Dexcom.Com and click on “Home User” and enter your login info.

I’m not sure what has started this issue either. I was told they had some recent update or other. I’ve also got a different receiver than when I first started with, but it was working fine for a couple of weeks before suddenly going wonky last week or so.

1 Like

Your upload to Clarity symptoms match mine. Having to wait for four hours for the data to appear via the cloud is not an acceptable situation. I’m glad to still have access to my up to the minute data to view in Clarity. This is what happens when a d-tech company produces a valuable system. Any threat to its usual operation reminds me how dependent I am on their technology.

Weird thing was that when I did the workaround, the date range that initially came up was for two weeks in August. “No patterns found”–no kidding. Be kinda surprising if there was since it was, y’know, in the future. Buggy, but the data were there.

Your workaround worked great. Thanks.

I want to give credit when it’s due. When I connect my Dexcom G5 receiver to my Mac laptop with a USB cable this morning, I no longer see the error message I wrote about in this thread. It appears that the Dexcom IT department has solved this glitch. Thank-you. I look at my BG data-stream every day. It makes a difference in the tactics I use. I know everyone is not as intent on this but it is a big deal to me.

1 Like

Giving it a try right now…

Edit: I suspect it all relates to this:

…and yes, it works. Ta da! Here’s a question for you Clarity pros though: I always get “We found no patterns during this date range.” What patterns are they talking about? I can see some fairly obvious ones–that’s why I use the thing. How come Clarity never detects any? Not that I care that much, just curious.

I’ve noticed the same thing. I’ve also seen Clarity pick up on some patterns. My conclusion is when Clarity doesn’t detect a “pattern,” it simply means that you haven’t exceeded some arbitrary pattern trigger the programmers chose to use. The “patterns” that Clarity refers to are highs or lows at specific times of the day. Here’s a screen-shot of ones I’m working with now:

I also notice some patterns before Clarity does and it does help me. When Clarity starts complaining then I really do need to up my game since I realize it is not as picky as me.

Which I absolutely know I do have and can see in the Clarity reports, that’s what’s so weird. But I guess if I can see 'em it’s not so important to me whether the Clarity algorithms do.