"Pump Not Primed" Error

On a couple of recent occasions, my Vibe has recently come up with a "Pump Not Primed" error message for no obvious reason. Priming 1 U has sorted the problem, but having to do so can be a nuisance because of the need to disconnect, which is not alwasy practical, when for example driving or in company.

On each occasion the cartridge has been in use for hours to a couple of days, so the problem is not associated with replacing the cartridge.

Any one else had this problem? I know the Vibe is not yet available in the USA but the basic pump is identical to the Ping and the 2020.


I had problems with one of my pings as well. The buttons on my original ping started to feel "soft", so they replaced it. The replacement pump did the "not primed" repeatedly. They walked me through all kinds of filling steps thinking that perhaps my technique was the issue. Having worn a pump for almost 20 years I was doubtful. The errors did not stop, so they sent me a third pump.... and problem was solved. I think it's a programming thing.

My only problems with my Ping came early on in my Animas career. I came from Medtronic where I was always told not to tighten my reservoir and battery caps too tightly. I had some priming issues early on and was told to make sure I really push the cartridge down when loading it and screw the cap on really tightly. Problem solved for me. Since you’ve used Animas for a while, that’s probably not your problem. Good luck getting it figured out.

When I first switched from MM I did have a few problems with "pump-not-primed" errors with newly inserted cartridges. With the MM522 I developed the habit of "overfilling" cartridges/reservoirs so that inserting the reservoir into the pump pushed insulin into the tubing. I tend to use the long tubing which takes about 25 units to prime. This significantly reduces the amount of insulin left in the reservoir. Also, the Animas will not prime more than 20 U, so you have to go back through the menu to prime the extra 5. However, the Animas also "expects" you to prime at least 10 U - if you prime less it generates a "pump-not-primed" error.

I now make sure I prime at least 10 U. The current problem, which is actually only occasional, can occur with a cartrige that has been in the pump for a day or longer. If it happens again, I will contact Animas technical help.

I have that problem quite often actually to this day and find that it's most likely my tubing being "occluded" aka the tubing is being cut off by me jeans or being pinned in an inefficient way in my pocket. Still need to do the repriming but it makes me a little less frustrated when I can put my finger on why it happens.

That happens on occasion to me (typically when the canula gets kinked) but I get an occulusion alarm which is different to a pump-not-primed alarm. I actually think the greater sensitivity to occlusions of the Animas compared to my old MM is a good thing. With the MM insulin delivery had to be virtually blocked before the alarm would trigger.


I’ve been using an Animas Ping for six years now. I’ve experienced several of these “pump not primed” errors. I was totally baffled the first few times this happened. I was also irritated that I had to do a complete screw rewind to fix the problem.

When I called Animas, the customer service rep cautioned me to make sure that the cartridge cap is screwed on firmly. Since I started doing that I’ve had no further errors like this.

Thanks for the info. That just might be the problem. As a former MM pumper, I am used to screwing the reservoir in with a light touch.

I have experienced this issue with whateve ping I have had. None seem to be immune to it. Frankly, I find it a real pain. Itis one of the reasons I've switched to the omnipod.

I’m having this problem. I’ve had 3 replacement pumps. It is seriously irritating. I really like my Ping a lot. This issue is frustrating, though.

I’m glad I looked this up and see your comments! I, too, started on Medtronic and have always used a light touch. Since I just had this error again, Idisconnected, rewound, primed, and just to see what happens, I tightened the cartridge cap very tight. Insulin squirted out! I feel silly that this could be the issue I’ve been having! I always have the cartridge cap on tight. Apparently not as tight as I should! Whoops!
I hope this fixes it! I’m so excited!! Thanks, everyone!!